Closed Bug 333869 Opened 15 years ago Closed 13 years ago

After changing designMode, the input element become unusable

Categories

(Core :: DOM: Editor, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: jzou3700, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

After change the designMode = on for editing, set designMode = off to back normal browser view mode. The input elements become unusable. They cannot be selected and cannot type anything into it. You could try it on http://www.mozilla.org/editor/midasdemo/ for this bug.

1) checking on View HTML Source 
2) typing <input>
3) checking off View HTML Source 
4) checking on read only

Now you can not type anything in the input element. I have try many other way to resolve the problem. But I found that once you chance the designMode, the input element will be unusable. Thanks for your response.

Reproducible: Always

Steps to Reproduce:
1) visiting http://www.mozilla.org/editor/midasdemo/ 
2) checking on View HTML Source 
3) typing <input>
4) checking off View HTML Source 
5) checking on read only

Actual Results:  
the Input element cannot work

Expected Results:  
I hope the input element could work.
This is also what has been described in bug 287707.
Depends on: 287707
Confirmed on nightly build 20060424.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → mozeditor
Component: Disability Access → Editor
Product: Firefox → Core
QA Contact: disability.access
Version: unspecified → 1.0 Branch
QA Contact: editor
Assignee: mozeditor → nobody
Duplicate of this bug: 379062
This is now fixed for me, now that bug 237964 is fixed.
Status: NEW → RESOLVED
Closed: 13 years ago
Depends on: contenteditable
No longer depends on: 287707
Resolution: --- → FIXED
Version: 1.0 Branch → Trunk
Blocks: 401821
You need to log in before you can comment on or make changes to this bug.