Firefox stays in memory after closing (involves hellomagazine.com popup)

VERIFIED INCOMPLETE

Status

()

--
critical
VERIFIED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: vladnb, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

After closing FireFox it stays in memory and I can not start firefox one more time.

Reproducible: Always

Steps to Reproduce:
1. Have all windows closed 
2. Start Firefox and go to www.hellomagazine.com
3. You see "the latest news" picture almost in the center of the page
4. Click it
5. You moved to latest news page with 2 pictures about it
6. You clock any of 2 picture
7. You are getting a pop-up windows with arrows to browse the pictures 
At this moment those arrows are working
8. You close parent window


Actual Results:  
In child (pop-up) window buttons-arrows to browse the images stop working. Even after closing of this pop-up window Firefox stays in memory. You can check that by Windows Taks Manager. And you can not start FireFox one more time.

Expected Results:  
1. Pop-up window continues working after closing of a parent window.
2. I can close and start Firefox anytime

1. This works well in MS IE whith IE 6.0.2900.2180.blabla
2. I like how your browser looks like.
Plse go to http://forums.mozillazine.org/viewforum.php?f=38 for support.

*** This bug has been marked as a duplicate of 239223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
This bug report has steps to reproduce, so it should block bug 239223 rather than being marked as a duplicate.  I don't know why Steve thought this was a support request.
Blocks: 239223
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: FireFox stops and stays in memory after closing → Firefox stays in memory after closing (involves hellomagazine.com popup)
Because Steve is stupid and couldn't reproduce the issue and found the repo steps to be ambiguous. So could this a Java issue?

Comment 4

13 years ago
The first time through with a debug trunk build from last night I got:

###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file c:\work\mozilla\builds\ff\trunk\mozilla\obj-dbg\dist\include\xpcom\nsCOMPtr.h, line 849

and then hung on exit. But when trying to see exactly where the assert fired in the steps, I could not reproduce and did not experience the hang again.

Comment 5

12 years ago
Unfortunately, the site has changed now, so I'm unable to reproduce given the steps above. Resolving as INCOMPLETE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.