Closed Bug 333989 Opened 18 years ago Closed 15 years ago

Finder Get Info window still shows old version after Software Update

Categories

(Toolkit :: Application Update, defect)

PowerPC
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 314794

People

(Reporter: jamie, Unassigned)

Details

(Keywords: polish)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

After Software Update updated Firefox on my machine from 1.5.0.1 to 1.5.0.2 (verified using the About window) the Finder Get Info window still shows it as being 1.5.0.1.

Reproducible: Always

Steps to Reproduce:
1) Launch Firefox 1.5.0.1 on Mac OS X (10.4.6)
2) Let it automatically update itself to 1.5.0.2 & restart itself.
3) Open the About Mozilla Firefox window, note that it says 1.5.0.2.
4) In the Dock, choose "Show In Finder" from the contextual menu for the Firefox icon.
5) Choose "Get Info" in the Finder
6) Look at the Version number in the "Firefox.app Info" window.

Actual Results:  
It says "Firefox 1.5.0.1, (c) 1988-2006 Contributors"

Expected Results:  
It should say 1.5.0.2.
Yup, this seems to happen with Software Update only. Downloads from FTP have the right version info in the Show Info.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Do we ever update Info.plist?
Flags: blocking1.8.0.3?
Flags: blocking-firefox2?
We update whatever the MAR file tells us to update.  If you need help inspecting the contents of the MAR files, let me know.  (HINT: look for dist/host/bin/mar.exe and tools/update-packaging/unwrap_full_update.sh)
From http://lxr.mozilla.org/mozilla/source/toolkit/xre/nsUpdateDriver.cpp#315 we *can* update info.plist so any changes to that file must not have made it into the mar file.
Did you restart the mac before checking again? Mac caches bundle data and you may just be seeing the cached data.
I don't see this using 10.3.9. The only difference is that I manually checked for the update - it found it, applied it, and "Get Info" shows 1.5.0.2.
(In reply to comment #6)
> Did you restart the mac before checking again? Mac caches bundle data and you
> may just be seeing the cached data.

No, my "Steps to Reproduce" accurately reflect what I did to see this.

In response to #2, #3, #4, and #5, info.plist has the correct updated version number, so that's not the issue. That mechanism is apparently working properly.

Executing "killall Finder" in Terminal.app and looking at Get Info again flushes the old info. So it does appear to be a Finder caching issue.

If there's a way to gracefully prod the Finder to take another look at info.plist without requiring a Finder relaunch, user log out/in, or (shudder) reboot, that would be nice. If not, or if the Finder will look again after a few minutes/hours on its own, I'd lump this in with the zillions of other Finder annoyances/bugs that I've encountered that have nothing to do with Firefox.
It seems important to address this problem because when the application still shows the old version number in the Finder, it looks like the update failed.  That tempts the user to unnecessarily download and install the latest version, which is a lot more work than using the otherwise-wonderful Software Update feature.

If there is no easy way to get the Finder to notice the change immediately, Software Update could at least throw up an announcement something like "The application has been successfully updated.  Due to OS X shortcomings, you won't see the new version number in the Finder until after you reboot."

Incidentally, Marcia Knous indicates that she did not experience this bug under 10.3.9 when she "manually checked for updates".  I did experience is under 10.3.9, when I updated in response to the automatic announcement.
I recommend WONTFIX for this bug. If somebody does want to do soemthing about this, the best way to go about it is probably using something in the Cocoa API's NSWorkspace class. You can note file system changes and trigger application re-registration with calls there.
Would be nice to have a fix, but not a 1.8.0.x blocker given the safe work-around of going to the About page.
Flags: blocking1.8.0.3? → blocking1.8.0.3-
Nice-to-have, at best.  The cobnirmation page should be enough here....
Flags: blocking-firefox2? → blocking-firefox2-
Keywords: relnote
OS: Mac OS X 10.2 → Mac OS X 10.4
I don't even think that this needs to be relnoted; it sounds like this is an over-aggressive OS X caching issue, and a nice polish issue to fix, but I really (really) doubt that we're going to see it as a bigtime support issue.
Keywords: relnotepolish
Product: Firefox → Toolkit
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.