Closed Bug 334067 Opened 15 years ago Closed 12 years ago

"Begin finding when you begin typing" causes find to come up even if a text box has the focus

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 331831

People

(Reporter: theschooligan, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

If "Begin finding when you begin typing" is enabled when Firefox starts, Firefox will begin finding when I start typing even if a text box has been given the focus.

For example, when I visit Google (which automatically gives its search box the focus on page load) and begin typing a query, the text that I'm typing shows up in the Firefox find text box as opposed to the search box on the page.

I have found that even if I click in a text box to give it the focus (as opposed to the page doing this automatically for me) the problem still occurs.

However, I have also found that if I disable "Begin finding when you begin typing" and then re-enable it, the problem no longer occurs.

Reproducible: Always

Steps to Reproduce:
1. Make sure that "Begin finding when you begin typing" is turned on.
   If it is not, enable it and restart the Firefox browser.
2. Navigate to Google (or any page with a text box).
3. Make sure that a text box on the page has the focus either by clicking on it or by letting it get the focus automatically (as is the case with Google).
4. Start typing in the text box.
Actual Results:  
The text that I typed appeared in the Firefox find text box.

Expected Results:  
The text that I typed should have appeared in the text box on the page that had the focus.
Not everyone experiences this problem.  You're not alone, though; see bug 320465. You might find information there that helps you fix the problem locally.

If you can figure out what additional setup causes you to experience this problem, that would help us a lot in fixing the bug(s).
Blocks: findgrabs
Same as bug number 331831
I have this problem too, from version 1.5 to 2.0RC1. I had to switch off "finding when typing" but it's not resolve my problem. Now when I try to type into input or textarea, sometimes focus caret is blinking on the field but it doesn't receive any character. Same with address bar or search bar. When it happen, I must switch to other window and then back to the browser.
I can reproduce this bug by opening a new window and selecting a bookmark, as Richard Aspden explained for bug 331831. It happens with this example page:
http://wargers.org/mozilla/fayt.php

It should be noted that when the problem happens, it affects only new windows. The previous windows work well, but if you open a third window when the second one has this bug, the new window also fails.
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 331831
You need to log in before you can comment on or make changes to this bug.