Closed Bug 334270 Opened 17 years ago Closed 17 years ago

typo in configure.in which breaks TARGET_XPCOM_ABI

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 322450

People

(Reporter: eric, Unassigned)

Details

Attachments

(1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060313 Debian/1.5.dfsg+1.5.0.1-4 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060313 Debian/1.5.dfsg+1.5.0.1-4 Firefox/1.5.0.1

On sparc, amd64 and ia64 the configure script improperly sets CPU_ARCH to a non-existant variable, instead of OS_TEST. This causes binary extensions to fail on these platforms apparently. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=359228.

x86_64 | sparc | ppc | ia64)
    CPU_ARCH="$CPU_ARCH_TEST"


Reproducible: Always
Attached patch trivial fix (obsolete) — Splinter Review
Attachment #218618 - Flags: review?
Looks to have been fixed on checkin in bug 322450, which still hasn't made it to branches.

*** This bug has been marked as a duplicate of 322450 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Attachment #218618 - Attachment is obsolete: true
Attachment #218618 - Flags: review?
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.