Closed Bug 334375 Opened 15 years ago Closed 15 years ago

Yahoo mail still crashing firefox after updating to 1.5.0.2 [@ ntdll.dll - nsVoidArray::SizeTo]

Categories

(Firefox :: General, defect)

1.5.0.x Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 326344

People

(Reporter: justabox76, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

When using yahoo mail firefox crashes.  I've noticed that the crash happens every time I open a second tab, be it for an email, a folder or anything resulting in two yahoo mail tabs being open at the same time.  I can have as many non yahoo tabs open as I want.

If I use yahoo mail in one tab only, and sign out when leaving, it will not crash.

I've been tracking related bug's here, and it was repeatedly stated that this bug would be fixed in release 1.5.0.2, much to my dismay it has not.

Reproducible: Always

Steps to Reproduce:
1.log into yahoo mail
2.open an email (i use middle click) in a seperate tab
3.count to 10



Expected Results:  
I get an error window that has been reported as unhelpful in other reported bugs for previous release.

I send track back reports but don't know how to retreive the number.

Not crashed and let me read my email in however many tabs I'd like.
I just went into my yahoo mail to get the error message.  It took me about 6 or 7 opening and closing of tabs to reproduce.  Here's the error message:


[quote]
firefox.exe-Application Error

The instruction at "0x7c9111e0" referenced memory at "0x00000005".  The memory could not be "read".
[/quote]
Trackback incident #'s:

TB17650100Q
TB17591567X

I tried to get another one but my trackback isn't connecting to the server just now.
BTW this happens both my office PC with fasterfox and Adblock

and my home PC with fasterfox, Adblock, forcastfox, bugmenot, and ie view installed.

If there is anything else you would like to know, or anything else I can do please let me know
From TB17591567X:
ntdll.dll + 0x11f6c (0x7c911f6c)
msvcrt.dll + 0x1c3c9 (0x77c2c3c9)
msvcrt.dll + 0x1c3e7 (0x77c2c3e7)
msvcrt.dll + 0x1c42e (0x77c2c42e)
nsVoidArray::SizeTo  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/ds/nsVoidArray.cpp, line 215]
Keywords: crash
Summary: Yahoo mail still crashing firefox after updating to 1.5.0.2 → Yahoo mail still crashing firefox after updating to 1.5.0.2 [@ ntdll.dll - nsVoidArray::SizeTo]
Version: unspecified → 1.5.0.x Branch
This should be a dupe of bug 326344. Reporter, please open about:plugins and look for Yahoo Application State Plugin.
yes i have that pluggin.  what happens to YIM functionality if i remove it?  and how do i remove it?
from bug 326344 comment 12:
>it looks that the purpose of the plugin is to tell Yahoo Mail, which version
>(if any) of Yahoo Messenger you have installed. It should then offer you some
>messenger links (voice mail) but it doesn't work because of a bug in
>ymsgr_is_messenger(). Still trying to figure out what exactly is causing this
>to crash...

To remove the plugin, move npYState.dll somewhere or just delete it. Not having used YIM myself, I am not sure where is it located, but it seems it would be in C:\Program files\Yahoo!\Share or in "plugins" folder inside Firefox progam folder. (You can set plugin.expose_full_path pref to true in about:config and then open about:plugins, it should mention the full path to the DLL.)

Please tell us if removing the DLL fixes the crash.
yes.  removing the pluggin seems to have fixed it.  thank you very much for resolving this issue.

does anyone know if it will be reinstalled next time i use YIM?

and it was in C:\Program Files\Yahoo!\Shared.

*** This bug has been marked as a duplicate of 326344 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ ntdll.dll - nsVoidArray::SizeTo]
You need to log in before you can comment on or make changes to this bug.