javascript handler when clicking on a link does not get called

VERIFIED DUPLICATE of bug 1646

Status

()

Core
JavaScript Engine
P2
major
VERIFIED DUPLICATE of bug 1646
19 years ago
16 years ago

People

(Reporter: Stephen P. Morse, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The following content should give an initial alert message and display a missing
image.  If that image is clicked on, a second alert message saying "in handler"
should appear.

In 4.5 it works as described above.  In 5.0, the second alert message does not
appear indicating that the handler was never called.

Needless to say, this is one of many bugs that are currently blocking
development of client-side wallet.

<html>
  <head>
    <script>
      function handler() {
        alert ("in handler");
      }
      alert("just a test to make sure alert works");
    </script>
  </head>
  <body>
    <form>
      <table>
        <tr>
          <td>
            <a HREF="javaScript:handler()">
              <IMG WIDTH="75" HEIGHT="40">
            </a>
          </td>
        </tr>
      </table>
    </form>
  </body>
</html>
(Reporter)

Updated

19 years ago
Summary: javascript handler when clicking an image does not get called → javascript handler when clicking on a link does not get called
(Reporter)

Comment 1

19 years ago
Example can be simplified further by changing the line:

   <IMG WIDTH="75" HEIGHT="40">

to be simply

   click me

Now this has nothing to do with any images but rather with links themselves.  So
the summary is being changes to reflect that.

Updated

19 years ago
Assignee: norris → vidur

Comment 2

19 years ago
This is almost certainly in the DOM, not JavaScript.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
This is a DUP of the javascript: bug. A workaround is to use the more
conventional onclick attribute. In this case:

<a HREF="" onclick="handler(); return false;">

*** This bug has been marked as a duplicate of 1646 ***

Comment 4

19 years ago
Javacsript component begin retired.  Moving this bug to Javascript Engine.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Verified Dup

Updated

16 years ago
Component: JavaScript Engine → Networking

Updated

16 years ago
Component: Networking → JavaScript Engine
You need to log in before you can comment on or make changes to this bug.