The default bug view has changed. See this FAQ.

Seamonkey update page appears in window with no navigation or tabs

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Aaron Lawrence, Assigned: Andrew Schultz)

Tracking

({fixed-seamonkey1.1a})

1.8 Branch
x86
Windows XP
fixed-seamonkey1.1a

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-seamonkey1.0.3)

Attachments

(1 attachment)

1.89 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: approval-seamonkey1.0.3+
Robert Kaiser
: approval-seamonkey1.1a+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
If you click Yes to update, when the "update available" appears, then you get a new window with no navigation (back, forward, URL etc) and no tabs bar. This makes it quite difficult to use. 
Expected: a normal browser window; actually, a normal browser tab, because I have it set to open new windows in tabs.

Seamonkey 1.0. Have installed 1.0.1 but can't recheck on demand - there's no way to do that, is there?
(Assignee)

Comment 1

11 years ago
http://lxr.mozilla.org/seamonkey/source/xpfe/components/updates/src/nsUpdateNotifier.js#266

I can't get update to kick in, but IIRC, windowWatcher uses its psychic powers to determine that we want a dialog because the last argument passed in is null (rather than an empty string).
Assignee: general → jag
Status: UNCONFIRMED → NEW
Component: General → XP Apps
Ever confirmed: true
QA Contact: general
(In reply to comment #0)
> 
> Seamonkey 1.0. Have installed 1.0.1 but can't recheck on demand - there's no
> way to do that, is there?
> 


If you enter in about:config, reset the preference:

update_notifications.provider.0.last_checked

to 0, restart SeaMonkey and browse the web for a while, it shouldn't pass too much time before you get the update notification.

BTW, I can confirm this behaviour in Windows (XP), and I can confirm that this doesn't happen in Linux (using IceWM).
I forgot to say that Bug 334339 is a dup of this one (or this one is a dup of 334339).
(Assignee)

Comment 4

11 years ago
Created attachment 228020 [details] [diff] [review]
patch

Let's not pretend a webpage is chrome!
Assignee: jag → ajschult
Status: NEW → ASSIGNED
Attachment #228020 - Flags: superreview?(neil)
Attachment #228020 - Flags: review?(neil)
(Assignee)

Comment 5

11 years ago
*** Bug 334339 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
Comment on attachment 228020 [details] [diff] [review]
patch

>+        var argstring = Components.classes["@mozilla.org/supports-string;1"].
>+           createInstance(Components.interfaces.nsISupportsString);
Nit: bogus 3-space indent, and . should be at the start of the second line.
Attachment #228020 - Flags: superreview?(neil)
Attachment #228020 - Flags: superreview+
Attachment #228020 - Flags: review?(neil)
Attachment #228020 - Flags: review+
(Assignee)

Comment 7

11 years ago
Comment on attachment 228020 [details] [diff] [review]
patch

This is on trunk, but won't actually be tested (by the masses) until it's in 1.0.x
Attachment #228020 - Flags: approval-seamonkey1.1a?
Attachment #228020 - Flags: approval-seamonkey1.0.3?

Comment 8

11 years ago
Comment on attachment 228020 [details] [diff] [review]
patch

a=me for 1.1, first-a=me for 1.0.x, still one needed to go
Attachment #228020 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+
Comment on attachment 228020 [details] [diff] [review]
patch

a=me for 1.0.3
Attachment #228020 - Flags: approval-seamonkey1.0.3? → approval-seamonkey1.0.3+
(Assignee)

Comment 10

11 years ago
landed on both branches
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed-seamonkey1.1a
Resolution: --- → FIXED
Whiteboard: fixed-seamonkey1.0.3
You need to log in before you can comment on or make changes to this bug.