XForms controls throws exception always

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: surkov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
If xforms control sees that something goes wrong then it thows always exception. It is right from the point of view of xforms but sometimes it is not quite right from the xforms author point of view.

In instace I make a xforms document from few xml documents. Model is described in one xml file, the xforms controls are described in other xml file. When I parse xml file with xforms controls then xforms controls throws excepions since they don't see model. I get exceptions in js console and they plague me with one's presence.

It is quite right behaviour from the xforms point of view but sometimes it is not useful.
(Reporter)

Comment 1

13 years ago
Created attachment 219272 [details]
testcase
(Reporter)

Comment 2

13 years ago
Probably we should provide mechanism to handle thease exceptions? Now afaik they are just information in js console.
(Reporter)

Comment 3

13 years ago
The bug is actual after bug 306247 patch applying.

Updated

13 years ago
Depends on: 306247

Comment 4

13 years ago
(In reply to comment #2)
> Probably we should provide mechanism to handle thease exceptions? Now afaik
> they are just information in js console.
> 

What are you looking for?  You want a preference to turn off/filter the JS Console warnings?  Or are you also asking for a preference so that we don't generate xforms-*-exception events?

Changing to enhancement since there is no 'bug' here.
Severity: minor → enhancement

Updated

13 years ago
Assignee: aaronr → xforms
(Reporter)

Comment 5

12 years ago
Worksforme since I don't see any errors in console and therefore I don't know where mechanism to handle errors is usefull :).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.