Closed Bug 334947 Opened 16 years ago Closed 16 years ago

freeze if drop vCard with base64 encoded photo

Categories

(MailNews Core :: Address Book, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: baffclan, Assigned: Bienvenu)

Details

(Keywords: fixed1.8.1, verified1.8.0.5, verified1.8.1.3)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060420 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060420 SeaMonkey/1.5a

freeze if drop vCard with base64 encoded photo


Reproducible: Always

Steps to Reproduce:
1. drop a vCard file with base64 encoded photo




Sometimes crashed : TB17798027K, TB17798014G
Attached file a brief sample file
1. save on desktop
2. drop to navigator
On 04/17, I made this change:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/mailnews/addrbook/src&command=DIFF_FRAMESET&file=nsVCard.cpp&rev1=1.4&rev2=1.4.4.1&root=/cvsroot

did this work with builds before that? I'm not having any problem with this on TB, however.
(In reply to comment #2)
> On 04/17, I made this change:
> 
> http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/mailnews/addrbook/src&command=DIFF_FRAMESET&file=nsVCard.cpp&rev1=1.4&rev2=1.4.4.1&root=/cvsroot
> 
> did this work with builds before that? I'm not having any problem with this on
> TB, however.
> 
If you received a email attached this file, TB will freeze.
yep
Assignee: nobody → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have a fix for this - I just need to attach it when I get to the machine that has the fix.
Attached patch proposed fixSplinter Review
if we get to the end of the hex data in the v-card without getting a string, return 0 as the type of data parsed, which will stop the v-card processing.
Attachment #223045 - Flags: superreview?(mscott)
Attachment #223045 - Flags: superreview?(mscott) → superreview+
fixed on trunk.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Attachment #223045 - Flags: approval-branch-1.8.1+
(In reply to comment #7)
> fixed on trunk.
cannot reproduce with Tb version 3 alpha 1 (20060525)/WinXP.(did not freeze.)
however, loss a attached vCard.

Steps to Reproduce:
1. make a new mail(open compose)
2. attached vCard file (e.g, attachment 219296 [details])
3. save to draft, and close compose
4. serect draft filder
5. click a mail (attached vCard)
6. not found attachmented file
Comment on attachment 223045 [details] [diff] [review]
proposed fix

This problem does occur with 1.5; since it hangs, is it worth putting on the release branch?
Attachment #223045 - Flags: approval1.8.0.4?
Comment on attachment 223045 [details] [diff] [review]
proposed fix

1.8.0.4 is done, moving approval request
Attachment #223045 - Flags: approval1.8.0.4? → approval1.8.0.5?
Comment on attachment 223045 [details] [diff] [review]
proposed fix

approved for 1.8.0 branch, a=dveditz for drivers

Please land on the 1.8 branch as well.
Attachment #223045 - Flags: approval1.8.0.5? → approval1.8.0.5+
v.fixed on 1.8.0 branch with Thunderbird version 1.5.0.5 (20060706), no hang viewing vcard.
Non hang occurs in Thunderbird 2, version 2.0.0.0 (20070326) on XP. Adding verified1.8.1.3 keyword.
Keywords: verified1.8.1.3
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.