"ASSERTION: Did not find ourselves on the placeholder's ancestor chain" involving relative and absolute positioning

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: jruderman, Assigned: roc)

Tracking

(Blocks 1 bug, {assertion, testcase})

Trunk
PowerPC
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

13 years ago
###!!! ASSERTION: Did not find ourselves on the placeholder's ancestor chain: 'f', file /Users/admin/trunk/mozilla/layout/generic/nsFrame.cpp, line 1302

The only mention of this assertion I can find is bug 317375 comment 51.
Reporter

Comment 1

13 years ago
Posted file testcase
In the case, the placeholder for aChild is a child of the next-in-flow of aFrame (because of the linebreak and because we stick the abs pos frames in the first-in-flow of the inline).

roc, does this function need changes to handle this case and similar cases?  Or does the assert need to change?
Flags: blocking1.9a1?
Reporter

Comment 3

13 years ago
Related to bug 288357 comment 19?
That's the block version of this, yes.  I was talking about it when I mentioned "similar cases" in comment 2.

Is there a bug on us not rendering the text in this case? That's a trunk regression from bug 317375 and should probably be blocking 1.9 alphas... It should probably also block this bug.
I can fix that here. That will help in bug 288357 too.
Blocks: 288357
Posted patch fixSplinter Review
This refactors the MarkOutOfFlow stuff, including the caret usage. The main thing is that nsDisplayListBuilder now records all the frames that were marked and unmarks them when the builder is destroyed (i.e. after all painting is done). This is actually a slight simplification and also fixes this bug by allowing the first-in-flow to mark a set of frames to be descended into even though we don't reach those frames until we paint one of its next-in-flows.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #219824 - Flags: review?(mrbkap)
Comment on attachment 219824 [details] [diff] [review]
fix

Looks good.
Attachment #219824 - Flags: review?(mrbkap) → review+
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Flags: blocking1.9a1?
Reporter

Comment 9

12 years ago
Crashtest checked in.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.