TestGtkEmbed won't refresh when resized

RESOLVED DUPLICATE of bug 312998

Status

()

Core
Embedding: APIs
RESOLVED DUPLICATE of bug 312998
12 years ago
12 years ago

People

(Reporter: Marko Ivancic, Assigned: dougt)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/Debian-1.5.dfsg+1.5.0.2-2 Firefox/1.5.0.2
Build Identifier: Minimo/0.015

TestGtkEmbed won't refresh when resized, until you click inside the unrefreshed area. It is something wrong with fireing up the visibility signal. Once you get visibility_cb 1 the test browser normaly refreshes on resizes. I tried to call gtk_show_widget(...) before/after showing the browser but works the same.

Reproducible: Always

Steps to Reproduce:
1.run TestgtkEmbed app
2. resize app (it won't properly refresh)
3. click inside the unrefreshed area
4. now refresh works

Actual Results:  
Won't refresh. Only if you load another page but when you resize it works the same.

Expected Results:  
When resized it could refresh. visibility signal has to be fired up ??
(Assignee)

Comment 1

12 years ago
need a stacktrace to be useful.
Status: UNCONFIRMED → NEW
Component: Minimo Front-End → Embedding: APIs
Ever confirmed: true
Product: Minimo → Core
Version: WinCE → 1.8 Branch
(Assignee)

Comment 2

12 years ago
need a stacktrace to be useful.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> need a stacktrace to be useful.
> 

Hi,

Complete stack trace of TestGtkEmbed, when you click inside the browser area and it starts to work corretly ( inside function visibility_cb(...) )

#0  visibility_cb (embed=0x8063780, visibility=1, browser=0x807c2d8) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/gtk/tests/TestGtkEmbed.cpp:884
#1  0xb7840adb in IA__g_cclosure_marshal_VOID__BOOLEAN (closure=0x8144478, return_value=0x0, n_param_values=2, param_values=0xbfc5836c, invocation_hint=0xbfc5825c,
    marshal_data=0x804b22c) at gmarshal.c:111
#2  0xb7833cb9 in IA__g_closure_invoke (closure=0x8144478, return_value=0x8063780, n_param_values=134625152, param_values=0x8063780, invocation_hint=0x8063780)
    at gclosure.c:490
#3  0xb7843c0a in signal_emit_unlocked_R (node=0x80c3010, detail=0, instance=0x8063780, emission_return=0x0, instance_and_params=0xbfc5836c) at gsignal.c:2438
#4  0xb7845490 in IA__g_signal_emit_valist (instance=0x8063780, signal_id=142, detail=0, var_args=<value optimized out>) at gsignal.c:2197
#5  0xb7ba3898 in gtk_signal_emit (object=0x8063780, signal_id=134625152) at gtksignal.c:360
#6  0xb7f380d3 in EmbedWindow::SetVisibility (this=0x8063780, aVisibility=-1077574804)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/gtk/src/EmbedWindow.cpp:378
#7  0xb6585c70 in nsDocShellTreeOwner::SetVisibility (this=0x81b6100, aVisibility=1)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/webBrowser/nsDocShellTreeOwner.cpp:654
#8  0xb6321281 in nsGlobalWindow::Activate (this=0x81d5948) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/dom/src/base/nsGlobalWindow.cpp:5401
#9  0xb6594497 in nsWebBrowser::Activate (this=0x81b6028) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/webBrowser/nsWebBrowser.cpp:1807
#10 0xb7f32739 in EmbedPrivate::ChildFocusIn (this=0x80c3d00) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/gtk/src/EmbedPrivate.cpp:771
#11 0xb7f30076 in handle_child_focus_in (aWidget=0x81b1e50, aGdkFocusEvent=0x8291a00, aEmbed=0x8063780)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/gtk/src/gtkmozembed2.cpp:751
#12 0xb7b56900 in _gtk_marshal_BOOLEAN__BOXED (closure=0x8206298, return_value=0xbfc58968, n_param_values=2, param_values=0xbfc58a64, invocation_hint=0xbfc58954,
    marshal_data=0xb7f3005c) at gtkmarshalers.c:83
#13 0xb7833cb9 in IA__g_closure_invoke (closure=0x8206298, return_value=0x8063780, n_param_values=134625152, param_values=0x8063780, invocation_hint=0x8063780)
    at gclosure.c:490
#14 0xb7843c0a in signal_emit_unlocked_R (node=0x8081818, detail=0, instance=0x81b1e50, emission_return=0xbfc58c24, instance_and_params=0xbfc58a64) at gsignal.c:2438
#15 0xb78451fe in IA__g_signal_emit_valist (instance=0x81b1e50, signal_id=39, detail=0, var_args=0xbfc58ca8 "À\214Å¿") at gsignal.c:2207
#16 0xb78457f9 in IA__g_signal_emit (instance=0x8063780, signal_id=134625152, detail=134625152) at gsignal.c:2241
#17 0xb7c483e4 in gtk_widget_event_internal (widget=0x81b1e50, event=0x8291a00) at gtkwidget.c:3751
#18 0xb7c58f21 in do_focus_change (widget=0x81b1e50, in=1) at gtkwindow.c:4629
#19 0xb7c593a7 in gtk_window_real_set_focus (window=0x8086828, focus=0x81b1e50) at gtkwindow.c:4854
#20 0xb784152b in IA__g_cclosure_marshal_VOID__OBJECT (closure=0x8084f18, return_value=0x0, n_param_values=2, param_values=0xbfc58fe4, invocation_hint=0xbfc58ed4,
    marshal_data=0xb7c59190) at gmarshal.c:636
#21 0xb78335f9 in g_type_class_meta_marshal (closure=0x8084f18, return_value=0x8063780, n_param_values=134625152, param_values=0xbfc58fe4, invocation_hint=0x8063780,
    marshal_data=0x8063780) at gclosure.c:567
#22 0xb7833cb9 in IA__g_closure_invoke (closure=0x8084f18, return_value=0x8063780, n_param_values=134625152, param_values=0x8063780, invocation_hint=0x8063780)
    at gclosure.c:490
#23 0xb7844315 in signal_emit_unlocked_R (node=0x8084f60, detail=0, instance=0x8086828, emission_return=0x0, instance_and_params=0xbfc58fe4) at gsignal.c:2476
#24 0xb7845490 in IA__g_signal_emit_valist (instance=0x8086828, signal_id=73, detail=0, var_args=<value optimized out>) at gsignal.c:2197
#25 0xb78457f9 in IA__g_signal_emit (instance=0x8063780, signal_id=134625152, detail=134625152) at gsignal.c:2241
#26 0xb7c55004 in _gtk_window_internal_set_focus (window=0x8086828, focus=0x81b1e50) at gtkwindow.c:1240
#27 0xb7c48eef in gtk_widget_real_grab_focus (focus_widget=0x81b1e50) at gtkwidget.c:4137
#28 0xb7840a2b in IA__g_cclosure_marshal_VOID__VOID (closure=0x8080498, return_value=0x0, n_param_values=1, param_values=0xbfc59514, invocation_hint=0xbfc59404,
    marshal_data=0xb7c48e30) at gmarshal.c:77
#29 0xb78335f9 in g_type_class_meta_marshal (closure=0x8080498, return_value=0x8063780, n_param_values=134625152, param_values=0xbfc59514, invocation_hint=0x8063780,
    marshal_data=0x8063780) at gclosure.c:567
#30 0xb7833cb9 in IA__g_closure_invoke (closure=0x8080498, return_value=0x8063780, n_param_values=134625152, param_values=0x8063780, invocation_hint=0x8063780)
    at gclosure.c:490
#31 0xb7844315 in signal_emit_unlocked_R (node=0x8080568, detail=0, instance=0x81b1e50, emission_return=0x0, instance_and_params=0xbfc59514) at gsignal.c:2476
#32 0xb7845490 in IA__g_signal_emit_valist (instance=0x81b1e50, signal_id=23, detail=0, var_args=<value optimized out>) at gsignal.c:2197
#33 0xb78457f9 in IA__g_signal_emit (instance=0x8063780, signal_id=134625152, detail=134625152) at gsignal.c:2241
#34 0xb7c46ac0 in IA__gtk_widget_grab_focus (widget=0x81b1e50) at gtkwidget.c:4056
#35 0xb665474e in nsWindow::SetFocus (this=0x82a0e40, aRaise=1) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/widget/src/gtk2/nsWindow.cpp:684
#36 0xb6245560 in nsEventStateManager::SendFocusBlur (this=0x82a07e8, aPresContext=0x82a0508, aContent=0x0, aEnsureWindowHasFocus=1)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/content/events/src/nsEventStateManager.cpp:4332
#37 0xb6244580 in nsEventStateManager::SetContentState (this=0x82a07e8, aContent=0x0, aState=2)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/content/events/src/nsEventStateManager.cpp:3972
#38 0xb624058b in nsEventStateManager::PostHandleEvent (this=0x82a07e8, aPresContext=0x82a0508, aEvent=0xbfc5a310, aTargetFrame=0x82a3cd0, aStatus=0xbfc5a078, aView=0x0)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/content/events/src/nsEventStateManager.cpp:2028
#39 0xb60667cd in PresShell::HandleEventInternal (this=0x82a3100, aEvent=0xbfc5a310, aView=0x82d3b50, aFlags=513, aStatus=0xbfc5a078)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/layout/base/nsPresShell.cpp:6450
#40 0xb6065fdd in PresShell::HandleEvent (this=0x82a3100, aView=0x82d3b50, aEvent=0xbfc5a310, aEventStatus=0xbfc5a078, aForceHandle=0, aHandled=@0xbfc5a07c)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/layout/base/nsPresShell.cpp:6214
#41 0xb6303528 in nsViewManager::HandleEvent (this=0x82a0d50, aView=0x82cdf58, aEvent=0xbfc5a310, aCaptured=0)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/view/src/nsViewManager.cpp:2557
#42 0xb6302c3e in nsViewManager::DispatchEvent (this=0x82a0d50, aEvent=0xbfc5a310, aStatus=0xbfc5a268)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/view/src/nsViewManager.cpp:2246
#43 0xb62fad7b in HandleEvent (aEvent=0xbfc5a310) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/view/src/nsView.cpp:171
#44 0xb6660279 in nsCommonWidget::DispatchEvent (this=0x82d3a60, aEvent=0xbfc5a310, aStatus=@0xbfc5a2b8)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/widget/src/gtk2/nsCommonWidget.cpp:219
#45 0xb6655e30 in nsWindow::OnButtonPressEvent (this=0x82d3a60, aWidget=0x81b1e50, aEvent=0x8291960)
    at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/widget/src/gtk2/nsWindow.cpp:1562
#46 0xb6659361 in button_press_event_cb (widget=0x81b1e50, event=0x8291960) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/widget/src/gtk2/nsWindow.cpp:3721
#47 0xb7b56900 in _gtk_marshal_BOOLEAN__BOXED (closure=0x81b9760, return_value=0xbfc5a520, n_param_values=2, param_values=0xbfc5a61c, invocation_hint=0xbfc5a50c,
    marshal_data=0xb665931c) at gtkmarshalers.c:83
#48 0xb7833cb9 in IA__g_closure_invoke (closure=0x81b9760, return_value=0x8063780, n_param_values=134625152, param_values=0x8063780, invocation_hint=0x8063780)
    at gclosure.c:490
#49 0xb7843c0a in signal_emit_unlocked_R (node=0x8080928, detail=0, instance=0x81b1e50, emission_return=0xbfc5a7dc, instance_and_params=0xbfc5a61c) at gsignal.c:2438
#50 0xb78451fe in IA__g_signal_emit_valist (instance=0x81b1e50, signal_id=27, detail=0, var_args=0xbfc5a860 "x¨Å¿`\031)\bP\036\033\bß\205Ä·P\036\033\bøÓ\a\b") at gsignal.c:2207
#51 0xb78457f9 in IA__g_signal_emit (instance=0x8063780, signal_id=134625152, detail=134625152) at gsignal.c:2241
#52 0xb7c483e4 in gtk_widget_event_internal (widget=0x81b1e50, event=0x8291960) at gtkwidget.c:3751
#53 0xb7b54d2d in IA__gtk_propagate_event (widget=0x81b1e50, event=0x8291960) at gtkmain.c:2195
#54 0xb7b551a3 in IA__gtk_main_do_event (event=0x8291960) at gtkmain.c:1424
#55 0xb79e8bfa in gdk_event_dispatch (source=0x8063780, callback=0, user_data=0x0) at gdkevents-x11.c:2291
#56 0xb77c31ac in IA__g_main_context_dispatch (context=0x807b100) at gmain.c:1916
#57 0xb77c663b in g_main_context_iterate (context=0x807b100, block=1, dispatch=1, self=0x807c250) at gmain.c:2547
#58 0xb77c6997 in IA__g_main_loop_run (loop=0x8290a60) at gmain.c:2751
#59 0xb7b54341 in IA__gtk_main () at gtkmain.c:1003
#60 0x08049e1a in main (argc=2, argv=0xbfc5aaf4) at /home/tom/tests/build/MOZILLA_1_8_BRANCH/mozilla/embedding/browser/gtk/tests/TestGtkEmbed.cpp:240

By

(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> I think this is a dup of bug 312998.
> 
Thank you. You are right. With this patch from bug 312998 now works great.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 312998 ***
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.