cannot see caret easily if caret is between some Chinese characters

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: masayuki, Assigned: roc)

Tracking

({jp-critical, regression})

Trunk
x86
Windows 2000
jp-critical, regression
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Now, bug 287813 and bug 334635 were fixed, we can see the new caret that is same color as forground color, and that is not ineverted. Therefore, when the caret is between some Chenese characters, we cannot see the caret to easy. See screenshot.

Updated

12 years ago
Summary: cannot see caret to easy if caret is between some Chinese characters → cannot see caret easily if caret is between some Chinese characters
Created attachment 219738 [details]
screenshot
I think that we have two way for fix.

1. the caret should be drawn non-background-color and non-foreground color.
2. we should ensure that the caret drawn area doesn't have any glyphs.

I think that (2) is not good for some languages. Because current implement breaks some script if the text has letter-spacing.

But I don't know what color is best for the caret in (1).
(Reporter)

Updated

12 years ago
Keywords: regression
what if we make the caret wider?
(In reply to comment #3)
> what if we make the caret wider?

Yeah, it's cool.

Comment 5

12 years ago
Just for Chinese text?  (A wide caret for English text, like Mozilla used to have, is kinda ugly and non-standard.)
(In reply to comment #5)
> Just for Chinese text?  (A wide caret for English text, like Mozilla used to
> have, is kinda ugly and non-standard.)

No, for all scripts. I'll work on this ASAP if nobody work on this.
Making the caret wider based on a test of the Unicode character before/after it should be not too hard to do.

Comment 8

12 years ago
-> masayuki per his comment
Assignee: nobody → masayuki
Created attachment 220108 [details]
screenshot of wide caret

wide caret(2px) is good for Chinese characters, but for latain text, I think that this seems to be too thick. Is it O.K.?
How about making it 2px wide if it's between two CJK characters, otherwise 1px?
Um... I don't have an idea for it. But I try it.
*** Bug 336086 has been marked as a duplicate of this bug. ***
We have a dup(bug 336086) that said the 't' has same problem. This is difficult, because this bug depends on the font.
(In reply to comment #13)
> We have a dup(bug 336086) that said the 't' has same problem. This is
> difficult, because this bug depends on the font.
> 

I was the reporter of that one... its interesting to note that it does not seem to occur with any numbers at all but does with some characters.
(Reporter)

Updated

12 years ago
Depends on: 359497
Flags: blocking1.9?
Flags: blocking1.9?
Whiteboard: [wanted-1.9]
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
Assignee: masayuki → roc
Created attachment 316946 [details] [diff] [review]
fix

This turned out to be incredibly simple. The patch makes the caret an extra CSS pixel thicker when it's positioned at a Kanji character. Seems to work great.

Masayuki, please try the patch and tell me if you like it.
Attachment #316946 - Flags: superreview?(mrbkap)
Attachment #316946 - Flags: review?(mrbkap)
Whiteboard: [needs review]
Comment on attachment 316946 [details] [diff] [review]
fix

Is it possible to replace the magic numbers with a meaningful identifier or a pointer to where you got them from? r+sr=mrbkap either way.
Attachment #316946 - Flags: superreview?(mrbkap)
Attachment #316946 - Flags: superreview+
Attachment #316946 - Flags: review?(mrbkap)
Attachment #316946 - Flags: review+
Whiteboard: [needs review] → [needs approval]
Comment on attachment 316946 [details] [diff] [review]
fix

Simple, low-risk fix for a CJK usability regression.
Attachment #316946 - Flags: approval1.9?
Comment on attachment 316946 [details] [diff] [review]
fix

a1.9+=damons
Attachment #316946 - Flags: approval1.9? → approval1.9+
checked in.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
-> v.

But the flexible caret width behavior is pretty strange. If I found some better idea, I'll file a new bug. But now this is ok. The accessibility issue is gone. Thank you, roc.
Status: RESOLVED → VERIFIED
Whiteboard: [needs approval]
You need to log in before you can comment on or make changes to this bug.