Fix import bookmarks instructions for 1.0.1 readme file (also relnotes)

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: m.testi, Assigned: alqahira)

Tracking

({fixed1.8.0.4, fixed1.8.1, relnote})

unspecified
PowerPC
Mac OS X
fixed1.8.0.4, fixed1.8.1, relnote
Bug Flags:
camino1.0.1 +

Details

(Whiteboard: [camino-1.0.1])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X

Current text: "In the resulting file dialog, choose the bookmarks file you wish to import, and click Open."
It refers to pre 1.0 operations.

Camino 1.0 can now directely import from others web browsers, like Firefox do.

So, I think, the correct instructions might be (please check English):

In the resulting file dialog, choose the web browser which you want to import your bookmarks from, and click Import. If your web browser is not listed, you can import an exported bookmarks file using the "Select a file" option. In the resulting file dialog, choose the bookmarks file you wish to import, and click Open. The bookmarks will be imported.

Reproducible: Always
I'm not sure if we need to take this for 1.0.1, though it would be nice. We definitely need to get it for the next release though.

Marcello: Do you think it'd be bad to have some translations listing the old instructions for 1.0.1 with the knowledge that they should be fixed in 1.0.2?

We were hoping to have the readme be finalized in this version... :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: camino1.0.2?
Flags: camino1.0.1?
Keywords: relnote

Comment 2

13 years ago
Since 101's being cracked open for the keychain thing anyway, we might as well make this doc fix and note the keychain fix.
Flags: camino1.0.2?
Flags: camino1.0.1?
Flags: camino1.0.1+
(Reporter)

Comment 3

13 years ago
These days most of the l10n teams are quite responsive, so if we decide to fix this one we can manage to update nearly all the translations. We shouldn't need to wait for 1.0.2 if we get additional translations. We could just reissue 1.0.1ML.
How about:

In the resulting file dialog, choose the web browser whose bookmarks you want to import and then click “Import”. If your web browser is not listed, you
can import an exported bookmarks file using the “Select a file” option. In the
resulting file dialog, choose the bookmarks file you wish to import, and click
“Open”. The bookmarks will be imported.

---

Is every browser's "exported" format the standard Netscape HTML format?  Otherwise I might change "exported" to "HTML" in that case.  

(Also note that, techically, "select a file" will import all the same "native bookmark formats" that the specific importers handle, e.g. if you've deleted your OmniWeb profile but have kept the bookmark file from the profile and stored it elsewhere.  But this is explained on cb.o/support, so no need to duplicate it in the readme ;) KISS.)

If that's OK, I can attach an updated Readme tonight and maybe l10n can get started on it, even if we have to rev the RelNotes again for the keychain fix and the p12 certif issue.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)

Small edit to simplify.

> How about:
> 
> [...] If your web browser is not listed, you
> can import any readable bookmarks file using the “Select a file” option. [...]

> (Also note that, techically, "select a file" will import all the same "native
> bookmark formats" that the specific importers handle, e.g. if you've deleted
> your OmniWeb profile but have kept the bookmark file from the profile and
> stored it elsewhere.

That's why I'm proposing this change, to leave the text more generic.
Created attachment 219950 [details]
Updated ReadMe.rtf

Adds my and Marcello's changes to the bookmarks pargaraph and unsplits an infinitive ;)

Also s/project web page/project website/ and s/This page/This site/ at the bottom of the file.
Attachment #219950 - Flags: review?(bugzilla)
Created attachment 219952 [details]
Revised relnotes

Replaces the .p12 certif entry with an entry for the keychain fix, in anticipation of the former being backed out and the latter being checked in for 1.0.1.  

(Change is also reflected on the wiki version)
Attachment #219952 - Flags: review?(bugzilla)
Comment on attachment 219950 [details]
Updated ReadMe.rtf

It gets a little awkward around "...choose the web browser whose bookmarks you want to import...".

Maybe something more like "...choose which web browser to import bookmarks from..."

Either way (with or without the change), r=me.
Attachment #219950 - Flags: review?(bugzilla) → review+

Comment 9

13 years ago
The broken PKCS#12 stuff was backed out, and 1.0.1 will have the keychain endian fix, so your notes are on target.
Comment on attachment 219952 [details]
Revised relnotes

Nits:

> "...in version 1.8.0.2 of the Mozilla Gecko..."

Since we're waiting for 1.8.0.3, let's change the relnotes to say so.

> "...Intel-based Mac..."
Pluralize that please or add "an" to the front of it (but then fix the rest of the line).

With those, r=me, but for now r-.
Attachment #219952 - Flags: review?(bugzilla) → review-
Summary: Fix import bookmarks instructions for 1.0.1 readme file → Fix import bookmarks instructions for 1.0.1 readme file (also relnotes)

Comment 11

13 years ago
If we have new real notes soon, we might be able to use tonight's nightly for 101.
Created attachment 219966 [details]
fixes nits in relnotes

Makes Sam happy?
Attachment #219952 - Attachment is obsolete: true
Attachment #219966 - Flags: review?(bugzilla)
Comment on attachment 219966 [details]
fixes nits in relnotes

r=me
Attachment #219966 - Flags: review?(bugzilla) → review+

Comment 14

13 years ago
I made minor changes to both files and checked them in.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.0.4, fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [camino-1.0.1]
Assignee: nobody → alqahira
You need to log in before you can comment on or make changes to this bug.