Closed Bug 335663 Opened 17 years ago Closed 17 years ago

deleting Text in Input-Field with Backspace produce Artefacts of Caret

Categories

(Core :: DOM: Editor, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: tobias, Assigned: mozeditor)

References

Details

(Keywords: regression)

Attachments

(1 file)

Using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060426 Mnenhy/0.7.3.10006 SeaMonkey/1.5a {Build ID: 2006042621}

everytime I delete some Charakters in Input-Area with Backspace, there will be some Artefacts, mostly in the same Line, but in MailNews-Composer also sometimes one or two Lines above. 

I suspect yesterdays checkin from Bug 334608 so I cc Blake to this. 


Steps to reproduce:
1. Set Focus and caret into Input-Field, URL-Bar or Bugzilla for example.
2. Type some Charakters.
3. Delete Charakters with Backspace. 

Result:
There will be some Artefacts from Caret be left. 


Thanks to Hartmut F., who has pointed to this Regression.
Add screenshot to show regression.
Blocks: 334608
Keywords: regression
Summary: deleting Caret with Backspace produce Artefacts → deleting Text in Input-Field with Backspace produce Artefacts of Caret
*** Bug 335681 has been marked as a duplicate of this bug. ***
same problem occurs at inputting IME. bug 335241 is back now.
Blocks: 335241
Sorry, ignore my previous comment. bug 335241 is scroll problem, it's still fixed. But the IME caret problem is back.
No longer blocks: 335241
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060427 Minefield/3.0a1 ID:2006042709 [cairo]

confirmed borked with FF
I think the patch in bug 334649 fixes this.
Depends on: 334649
Camino reproduces. 

Mac OS X 10.3.9
2006042800 (v1.2+)
Hardware: PC → All
Actually, I backed out the offending changes since they caused other problems too.
Status: NEW → RESOLVED
Closed: 17 years ago
No longer depends on: 334649
Resolution: --- → FIXED
Verified fixed with Creature-Trunk-Tinderbox-Build 2006042723. Blakes backout of the Patch for Bug 334608 (attachment 219410 [details] [diff] [review]) hase solved this. 

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.