Last Comment Bug 335757 - Addons Manager behave wrong and gets broken if XPI is not found on the server during update
: Addons Manager behave wrong and gets broken if XPI is not found on the serve...
Status: RESOLVED FIXED
: fixed1.8.1, regression
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: mozilla1.8.1beta2
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
: Andy McKay [:andym]
Mentors:
http://caspar.regis.free.fr/tests/tes...
Depends on: 338028 341161
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 16:48 PDT by Régis Caspar
Modified: 2008-07-31 04:30 PDT (History)
5 users (show)
mconnor: blocking‑firefox2+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Régis Caspar 2006-04-27 16:48:55 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060427 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060427 Minefield/3.0a1

With the new Addon Manager if un update is found and you choose to install it, when the updated XPI is not found you get an error -207 in a message box. That's OK. After that any extension you try to install will give you the same error message. That's not OK if the XPI *is* on the server.

See URL (= testcase) for steps to reproduce, screenshots.

Everything goes back to normal after a restart

Reproducible: Always

Steps to Reproduce:
1. See URL

Actual Results:  
wrong error message, staying "Installing...", restart button disabled

Expected Results:  
no error, no staying "Installing...", restart button enabled
Comment 1 u88484 2006-04-27 17:06:21 PDT
Confirmed with test case
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2006-04-27 23:57:26 PDT
I highly suspect this was the case before but we didn't display it in the ui... I'll take a look at what needs to be done to fix this.
Comment 3 Dave Townsend [:mossop] 2006-06-10 04:03:48 PDT
I'm unable to reproduce this on trunk or branch builds. The error number displayed is different for me, but after that installing extensions works ok. The UI is a bit messed up though, the failed update for foobar still displays a progress bar, and the XForms installation has two entries, one saying "installing" and another saying that XForms will work after restart.
Comment 4 Régis Caspar 2006-06-10 05:12:40 PDT
(In reply to comment #3)
> I'm unable to reproduce this on trunk or branch builds. The error number
> displayed is different for me, but after that installing extensions works ok.
> The UI is a bit messed up though, the failed update for foobar still displays a
> progress bar, and the XForms installation has two entries, one saying
> "installing" and another saying that XForms will work after restart.
Same things here, a -228 error but extension installation works fine after that. I see the same UI glitches (+ the restart button staying disabled) besides the duplicate entry for XForms. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060609 Minefield/3.0a1 ID:2006060904 [cairo]
Comment 5 Dave Townsend [:mossop] 2006-06-11 10:07:16 PDT
Ok I've been able to reproduce the download error for the second extension installation, I simply install an extension which succeeds then try installing xforms which displays a download error, then succeeds to install.

Both the download error, and the bogus XForms entry left over as described above are XPInstall issues.

I will provide a patch shortly to do something about the dead progress bar from the failed update.
Comment 6 Dave Townsend [:mossop] 2006-06-11 11:34:34 PDT
Filed bug 341166 for the progress bar and restart button problem since it's a somewhat different problem to this.
Comment 7 Mike Beltzner [:beltzner, not reading bugmail] 2006-07-05 12:30:49 PDT
--> beta2, need to add a relnote
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2006-07-05 12:35:27 PDT
I believe that fixing bug 338028 and bug 341161 will take care of this bug... at the very least we need those fixed to fix this bug.
Comment 9 Dave Townsend [:mossop] 2006-07-05 12:55:15 PDT
Yes thats right. Without both fixes, the release note would go something like "In certain circumstances attempting to instal a second extension in a single Firefox session will appear to fail and exhibit problems in the Addons manager."

In my opinion this problem would have existed in some form or other since the extension manager existed.

Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2006-07-05 12:56:15 PDT
(In reply to comment #9)
> ...
> In my opinion this problem would have existed in some form or other since the
> extension manager existed.
It has... it is just more noticeable since the ui re-write. :(

Comment 11 Mike Connor [:mconnor] 2006-07-18 09:42:27 PDT
We're gated on reviews for the dependencies here.
Comment 12 Dave Townsend [:mossop] 2006-07-19 06:33:34 PDT
This should be fixed on trunk now.
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2006-07-22 17:27:47 PDT
This should be fixed on the MOZILLA_1_8_BRANCH now that the patches for bug 338028 and bug 341161 have been checked in.

Note You need to log in before you can comment on or make changes to this bug.