Closed Bug 335820 Opened 14 years ago Closed 14 years ago

engine icons in the search engine manager need padding

Categories

(Firefox :: Search, defect, minor)

2.0 Branch
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 2 beta1

People

(Reporter: Gavin, Assigned: Gavin)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file, 2 obsolete files)

The text is flush against the icon, some spacing would make it look nicer.
Depends on: 232272
Attached image Search button and drop-down at right (obsolete) —
How's this?
Comment on attachment 220180 [details]
Search button and drop-down at right

Sorry, this got atatched to the wrong bug.
Attachment #220180 - Attachment is obsolete: true
*** Bug 338018 has been marked as a duplicate of this bug. ***
Also the 'move up' and 'move down' buttons need to use the styling as defined in /global/skin/arrows.css (.up and .down) instead of its own #up and #dn, which are only stylable through /global/skin/global.css, making that one very polluted.

So, in the Manage Search Engine xul file change 'id=#up' to class="up", and link 'arrows.css' as style sheet.
Those IDs are just used to (In reply to comment #4)
> Also the 'move up' and 'move down' buttons need to use the styling as defined
> in /global/skin/arrows.css (.up and .down) instead of its own #up and #dn,
> which are only stylable through /global/skin/global.css, making that one very
> polluted.

Please file a new bug for this. A patch would be welcome, too :)
Attached patch add a margin (obsolete) — Splinter Review
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #226015 - Flags: review?(mconnor)
Attachment #226015 - Flags: approval-branch-1.8.1?(mconnor)
Whiteboard: [patch-r?]
Comment on attachment 226015 [details] [diff] [review]
add a margin

r=me if you preprocess the headers out of the css files , remember its % now for CSS
Attachment #226015 - Flags: review?(mconnor)
Attachment #226015 - Flags: review+
Attachment #226015 - Flags: approval-branch-1.8.1?(mconnor)
Attachment #226015 - Flags: approval-branch-1.8.1+
Whiteboard: [patch-r?] → [checkin needed+]
checked in, branch and trunk.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [checkin needed+]
Target Milestone: --- → Firefox 2 beta1
Attached patch as checked inSplinter Review
Attachment #226015 - Attachment is obsolete: true
(In reply to comment #8)
> checked in, branch and trunk.

In the build 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060620 Minefield/3.0a1 ID:2006062003 [cairo]
there's still no padding between the engine's icons and names.
Works for me, using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060620 Minefield/3.0a1.
You need to log in before you can comment on or make changes to this bug.