Closed Bug 335877 Opened 15 years ago Closed 15 years ago

imap subscribe ui broken for servers with non '/' hierarchy delimiter

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Details

(Keywords: fixed1.8.1, regression)

Attachments

(1 file)

if your server uses a character like '.' for the hierarchy delimiter (e.g., Courier or Cyrus), we don't display hierarchies correctly.
Attached patch proposed fixSplinter Review
IMAP always passes paths with the canonical delimiter to the subscribe ui, so the delimiter should be '/'. Somehow this code used to work because we would end up passing in '/' as the delimiter even if the real delimiter was '.' (I verified this with 1.5.0.3, where everything works fine). I checked that subscribing and unsubscribing works after this change.
Attachment #220194 - Flags: superreview?(mscott)
Attachment #220194 - Flags: superreview?(mscott) → superreview+
Status: NEW → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Verified FIXED using build 2006-04-29-05 of SeaMonkey trunk under Windows XP with Cyrus IMAP4 Murder v2.2.10.

This affected me and I didn't even catch it, thanks David!
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.