New instances of browsers hang when an unverified c

RESOLVED DUPLICATE of bug 74331

Status

()

defect
RESOLVED DUPLICATE of bug 74331
13 years ago
13 years ago

People

(Reporter: data0213, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

This looks related to Bug 242275. If you go to a secure site with an invalid certificate, and you start a new instance of the browser to browse while you are examining the certificate, no requests go through. Browsing resumes normally after you hit cancel/ok.

I could not do a whois search on the site while I was examining the certificate. 

MT

Reproducible: Always

Steps to Reproduce:
1. Go to https://www.donotcall.gov/default.aspx or any site where the certificate is invalid
2. You should get a "Certificate Invalid" dialog
2. Open a new instance of Firefox
3. Try to browse anywhere

Actual Results:  
You cannot browse to any site till you hit ok/cancel

Expected Results:  
You should be able to browse while the certificate is up

Comment 1

13 years ago
Seems to me the certificate at the URL specified is valid? Not getting a dialog.
Is this a modal dialog you're seeing? Then your report may be a dupe of bug 74331.
Summary: New instances of browsers hang when an unverified certificate dialog is active → New instances of browsers hang when an unverified c
Component: Safe Browsing → General
QA Contact: safe.browsing → general
It is, on both counts: modal, and blocking networking.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.