Window location isn't remembered when browser is closed while maximized on multi-monitor setup

RESOLVED DUPLICATE of bug 264030

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 264030
12 years ago
11 years ago

People

(Reporter: bikrrr, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

On a multi-monitor setup using Windows native multiple monitor support (not NVIDIA's or ATI's), if you move the Firefox browser to a different monitor, maximize the window then close the browser, Firefox will not open in the last monitor it was located it. It will only open in the monitor that it was last closed while in a non-maximized or "restored" state.

Reproducible: Always

Steps to Reproduce:
1. Setup multi-monitor using Windows XP (right-click desktop and choose properties, click on Settings tab- you'll need either a dual-head video card or two video cards in the same system)
2. Open Firefox
3. Take note which monitor it opens in
4. Move the Firefox window to a different monitor
5. Maximize the Firefox window
6. Exit Firefox
7. Launch Firefox again

Actual Results:  
Firefox opens in the original window noted in Step 3. It does remember to open Maximized, but in the wrong window.

Expected Results:  
Firefox should open maximized in the window it was moved to in Step 4.

Interesting to note that this ONLY HAPPENS WHEN MAXIMIZED. If you repeat the Steps to Repro and leave out Step 5, it will work as expected. Firefox will properly remember the last monitor it was in.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
(Reporter)

Updated

11 years ago
Version: 1.5.0.x Branch → 2.0 Branch

Comment 1

11 years ago
Bug 264030 doesn't require the window to be maximized, but looks like the same
issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264030
You need to log in before you can comment on or make changes to this bug.