The default bug view has changed. See this FAQ.

XUL: Non-relevant controls should not be shown

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
11 years ago
9 months ago

People

(Reporter: Allan Beaufour, Assigned: surkov)

Tracking

({fixed1.8.0.5, fixed1.8.1})

Trunk
fixed1.8.0.5, fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

691 bytes, application/vnd.mozilla.xul+xml
Details
1.31 KB, patch
Allan Beaufour
: review+
smaug
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
Controls bound to non-relevant nodes should not be shown per default (like for XHTML).
(Reporter)

Comment 1

11 years ago
Created attachment 220912 [details]
Testcase
(Assignee)

Comment 2

11 years ago
Created attachment 221041 [details] [diff] [review]
patch

It's pretty simple patch but I don't like a lot !important flag. The problem is style for :disabled is applied before other styles. !important solves the problem but is it right?
Attachment #221041 - Flags: review?(allan)
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 3

11 years ago
Comment on attachment 221041 [details] [diff] [review]
patch

(In reply to comment #2)
> Created an attachment (id=221041) [edit]
> patch
> 
> It's pretty simple patch but I don't like a lot !important flag. The problem is
> style for :disabled is applied before other styles. !important solves the
> problem but is it right?

No, because then it cannot be overriden by the form author.
Attachment #221041 - Flags: review?(allan) → review-
(Assignee)

Comment 4

11 years ago
(In reply to comment #3)
> (From update of attachment 221041 [details] [diff] [review] [edit])
> (In reply to comment #2)
> > Created an attachment (id=221041) [edit]
> > patch
> > 
> > It's pretty simple patch but I don't like a lot !important flag. The problem is
> > style for :disabled is applied before other styles. !important solves the
> > problem but is it right?
> 
> No, because then it cannot be overriden by the form author.
> 

Not quite, it can override by using '!important' flag :)

How about the such approach?
(Assignee)

Comment 5

11 years ago
Created attachment 221560 [details] [diff] [review]
patch2
Attachment #221041 - Attachment is obsolete: true
Attachment #221560 - Flags: review?(allan)
(Reporter)

Comment 6

11 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > (From update of attachment 221041 [details] [diff] [review] [edit] [edit])
> > (In reply to comment #2)
> > > Created an attachment (id=221041) [edit]
> > > patch
> > > 
> > > It's pretty simple patch but I don't like a lot !important flag. The problem is
> > > style for :disabled is applied before other styles. !important solves the
> > > problem but is it right?
> > 
> > No, because then it cannot be overriden by the form author.
> > 
> 
> Not quite, it can override by using '!important' flag :)

No, because I tbelieve that our agent style sheet is a "user stylesheet":
"Both author and user style sheets may contain "!important" declarations, and user "!important" rules override author "!important" rules."
[http://www.w3.org/TR/REC-CSS2/cascade.html#important-rules]
(Reporter)

Comment 7

11 years ago
Comment on attachment 221560 [details] [diff] [review]
patch2

I'm not sure I like the approach, but it's css styling. Off we go :)

r=me
Attachment #221560 - Flags: review?(allan)
Attachment #221560 - Flags: review?(Olli.Pettay)
Attachment #221560 - Flags: review+
Attachment #221560 - Flags: review?(Olli.Pettay) → review+
(Reporter)

Comment 8

11 years ago
Fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Reporter)

Updated

11 years ago
Keywords: fixed1.8.1
(Reporter)

Updated

11 years ago
Keywords: fixed1.8.0.5
(Reporter)

Updated

11 years ago
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.