Firefox 1.5.0.3 crashing after extension install

RESOLVED DUPLICATE of bug 259688

Status

()

--
critical
RESOLVED DUPLICATE of bug 259688
13 years ago
10 years ago

People

(Reporter: aniraj4u, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I have autoupdated Firefox 1.5.0.3 from the previous release of 1.5.0.2.
All my old extensions gone and not in the extensions list.

I started reinstalling them. Everytime I am installing a new extension
firefox crashes after installation completion.After restarting firefox
I found the extension has been successfully installed and I can use that 
extension without problem.

But the problem remains, when installing a new extensions. I have'nt checked
it while updating a extensions.

Reproducible: Always

Steps to Reproduce:
1.Update Firefox from 1.5.0.2 to 1.5.0.3
2.Web install a new extensios
3.After download and install firefox will crash.

Actual Results:  
Firefox Crash

Expected Results:  
Should not crash

God knows.
Does talkback (e.g. quality feedback agent) display when it crashes? If not could you download the installer so talkback can be installed by selecting custom install and selecting it in the optional components? If it is already installed or after it is installed it should display after a crash and ask to submit an incident id. After the incident is submitted open explorer and go to the application's directory. Once there go to the extensions\talkback@mozilla.org\components directory and launch talkback.exe to display the incident ids. Post in this bug the first incident id in the list. Thanks
http://www.mozilla.org/quality/qfa.html
(Reporter)

Comment 2

13 years ago
I am sorry I forgot to mention that it happens only when u click more than once on the link "Install Now" on the firefox extension's webpage. 

You can check it yourself easily by reproducing it by following steps.
(We will be reproducing with a extension e.g FlashGot)

1. Uninstall FlashGot extension if already installed.
2. Restart FireFox
3. Go to this page https://addons.mozilla.org/firefox/220/
4. Click 2-3 times in the "Install Now" link
5. The first Install extension window will pop-up. Select "Install"
6. Choose "Cancel" for other install extension popups
7. Wait for the download to complete and installation.

Now FireFox is gone with a nasty MS crash error report message.



(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3)
> Gecko/20060426 Firefox/1.5.0.3
> 
> I have autoupdated Firefox 1.5.0.3 from the previous release of 1.5.0.2.
> All my old extensions gone and not in the extensions list.
> 
> I started reinstalling them. Everytime I am installing a new extension
> firefox crashes after installation completion.After restarting firefox
> I found the extension has been successfully installed and I can use that 
> extension without problem.
> 
> But the problem remains, when installing a new extensions. I have'nt checked
> it while updating a extensions.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Update Firefox from 1.5.0.2 to 1.5.0.3
> 2.Web install a new extensios
> 3.After download and install firefox will crash.
> 
> Actual Results:  
> Firefox Crash
> 
> Expected Results:  
> Should not crash
> 
> God knows.
> 


*** This bug has been marked as a duplicate of 259688 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.