Closed Bug 336877 Opened 14 years ago Closed 14 years ago

XMLHttpRequest: foo.onreadystatechange.handleEvent() not working

Categories

(Core :: XML, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: dao, Unassigned)

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060505 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060505 Minefield/3.0a1

Please take a look at the test case I'm going to attach.
Firebug shows that the request was successful, but the callback assigned to onreadystatechange isn't called because of this:

Error: [Exception... "Not enough arguments"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: chrome://firebug/content/firebug.js :: anonymous :: line 628"  data: no]
Source File: chrome://firebug/content/firebug.js
Line: 628

Line 628 is spy.onreadystatechange.handleEvent();


To get this error, you'll need Firebug with "Show XMLHttpRequests" enabled.


I see this with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060505 Minefield/3.0a1 ID:2006050511 [cairo]
Working with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060504 Minefield/3.0a1 ID:2006050405 [cairo]

Regressed by bug 198595?

Reproducible: Always
Attached file test case
Bugs on Firebug are not mozilla.org bugs.  Firebug is an extension that lives outside mozilla.org code.  Therefore, this bug is INVALID.

I'm cc'ing myself in case you disagree.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
How do you know the bug is with Firebug, and not with something in Gecko that Firebug relies on? The fact that an extension is involved doesn't make a bug necessarily invalid.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Especially since there is a regression range corresponding to a gecko change. If Firebug was relying on something broken, we should at least know what before closing the bug as invalid.
Firebug will need to be changed to pass the event object it gets in the callback as an argument to handleEvent.
Yeah, this is invalid.  Firebug was using a private unfrozen API, and we changed that API.

Please do file a bug on Firebug.

Alex, Gavin is right.  Generally speaking, if we break an extension it might well be a bug in our code, so just being an extension does not make a bug invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.