bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Netcenter search pages are supposedly UTF-8 encoded, but are sending back bad data

CLOSED FIXED in M16

Status

SeaMonkey
Search
P2
normal
CLOSED FIXED
19 years ago
10 years ago

People

(Reporter: Robert John Churchill, Assigned: Jared Linley)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

(Reporter)

Description

19 years ago
In Mozilla, if you search Netcenter (see exact full URL above) for "Jennifer 
Lopez", you'll notice that the list of results in the sidebar is incorrect. (We 
only display five results.)

Look carefully at the third "Web Site Category" item. Its "Lopez, Jennifer - 
found in: World>Espanol>...". Notice how the "ñ" in "Español" is an n-umlaut.

If you look at the HTML source, you'll find:

<LI><a 
href="http://directory.netscape.com/World/Español/Artes/Cine/Actrices_y_Actores/
L/Lopez,_Jennifer">

but the n-umlaut isn't UTF-8 encoded.

We either need all Netcenter search data to be properly UTF-8 encoded, or if 
they are using some other encoding, the associated encoding numbers needs to be 
described in all of our Netcenter Sherlock files.

Without this being fixed, Netcenter search results with improperly encoding data 
will cause problems with Mozilla's search sidebar panel.

John, can you work on this with Netcenter folks?  Thanks.
(Reporter)

Comment 1

19 years ago
Quick typo fix:

Look carefully at the third "Web Site Category" item. Its "Lopez, Jennifer - 
found in: World>Español>...". Notice how the "ñ" in "Español" is an n-umlaut.
(Reporter)

Comment 2

19 years ago
As another example of something being bad with Netcenter search results on 
"Jennifer Lopez" when using Mozilla, do the search using the URL given for this 
bug, then select the menu:
    "View->Character Encoding->Multibyte->Unicode (UTF-8)"

You'll notice how the page contents stop on the third "Web Site Category" 
item... i.e. the line with the n-umlaut that is improperly encoded.
(Reporter)

Comment 3

19 years ago
Same exact encoding problem when searching for "Netcenter".

(Reporter)

Comment 4

19 years ago
John, any luck with the Netcenter folks at fixing this encoding problem?
(Reporter)

Comment 5

19 years ago
Jared, can you fix this encoding problem?
Assignee: johng → jlinley
Priority: P3 → P2
Target Milestone: --- → M15

Comment 6

19 years ago
How come this is still M15? M15 is already out!
(Reporter)

Comment 7

19 years ago
Any new status on this bug?
Target Milestone: M15 → M16
(Assignee)

Comment 8

19 years ago
We are in the process of UTF-8 encoding our data and templates. I'll update this 
bug with an ETR asap.
Status: NEW → ASSIGNED
(Assignee)

Comment 9

18 years ago
Our new ETR for this bug is 6/1, however we have a dependency on the 
installation of NES 4.1. Barring problems with NES we should have UTF-8 encoding 
across Netscape Search by 6/1.
(Assignee)

Comment 10

18 years ago

*** This bug has been marked as a duplicate of 26260 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 11

18 years ago
My mistake, this is not a duplicate #35630 and #26260 are duplicates
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 12

18 years ago
nominating nsbeta2
Keywords: nsbeta2

Comment 13

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 14

18 years ago
Adding netcenter keyword.
Keywords: netcenter

Comment 15

18 years ago
The URL only works if Español is entered as Espa%c3%b1ol. This bug exists in 
older browsers as well, so it is not an issue with NS6.
(Assignee)

Comment 16

18 years ago
This bug is fixed with the UTF-8 encoded data and NPE plugin.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
Closing.
Status: RESOLVED → CLOSED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.