Closed Bug 337114 Opened 14 years ago Closed 14 years ago

css import not contained in save web complete

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 126309

People

(Reporter: alexgenaud, Unassigned)

Details

Attachments

(1 file)

4.36 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

when saving web page complete, all resources are expected to be downloaded in xxx_files directory. However, many pages import css files, which are not included in the web page complete directory. Thus pages are unstyled when viewed offline.

   <style type="text/css">

      @import url(logo.css);

   </style>



Reproducible: Always

Steps to Reproduce:
1. open page with css import
2. File > Save Page As... > Save as type > Web page, complete
3. open downloaded resource

Actual Results:  
the offline page is not styled as the online page is

Expected Results:  
the offline page should download all (or as many) resources necessary to reproduce the page.
Attached file minimal example
this is a test minimal example. The zip contains index.html which references two images, a javascript file, and a css (by @import).

Open the index.html file. Then "Save As..." "Web page, complete". Open the newly saved page. Because the css file will not be present, the images will not be on the same line (as they are in the original).
I think it's a duplicate of bug 126309
(In reply to comment #2)
> I think it's a duplicate of bug 126309
> 

Yes, it is.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.