Closed Bug 337130 Opened 18 years ago Closed 18 years ago

http basic authentication does not send username/password using the charset specified by the page

Categories

(Core :: Networking: HTTP, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 41489

People

(Reporter: bz, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

http auth only works with ascii for username and password.
Even if Content Type is set to UTF-8
Internet Explorer has the same bug. Opera works fine.

http://lamp2.fh-stpoelten.ac.at/~lbz/beispiele/ss2006/support/login.phps

Reproducible: Always
You server seems misconfigured, I get the php source for that...
(In reply to comment #1)
> You server seems misconfigured, I get the php source for that...
> 

I added the URL for the "active" version in the URL field.
http://lamp2.fh-stpoelten.ac.at/~lbz/beispiele/ss2006/support/login.php
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a3) Gecko/20060621 BonEcho/2.0a3 ID:2006062104.
Status: UNCONFIRMED → NEW
Component: General → Networking: HTTP
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → networking.http
Summary: http auth with german umlauts in username or passwort → http basic authentication does not send username/password using the charset specified by the page
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 41489 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.