Note: There are a few cases of duplicates in user autocompletion which are being worked on.

select1, hooking up a send to ev:xforms-select only works the first time

RESOLVED FIXED

Status

Core Graveyard
XForms
P1
normal
RESOLVED FIXED
11 years ago
a year ago

People

(Reporter: Allan Beaufour, Assigned: aaronr)

Tracking

({fixed1.8.0.5, fixed1.8.1})

Trunk
fixed1.8.0.5, fixed1.8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

2.63 KB, application/xhtml+xml
Details
1012 bytes, patch
Doron Rosenberg (IBM)
: review+
smaug
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
If I hook up a send to an xforms-select on a xforms:select1, it only triggers the submission the first time. On subsequent selects I get this error:

Error: elm.parentNode has no properties
Source File: chrome://xforms/content/select1.xml
Line: 942
(Reporter)

Comment 1

11 years ago
Created attachment 221307 [details]
Testcase
(Reporter)

Updated

11 years ago
Blocks: 331209
Priority: -- → P1
(Reporter)

Comment 2

11 years ago
Possibly a dupe of 332292?
(Reporter)

Comment 3

11 years ago
Created attachment 223042 [details] [diff] [review]
Crude fix

Aparently the selected element does not always have a parent node? Checking for that makes the dispatchEvent() work.

It does not fix the testcase 100%, because the xforms-select event is sent before the node value is changed, so the result gotten from the server is "lagging". But it might be correct event sequencing? Dunno.
Attachment #223042 - Flags: review?(doronr)

Comment 4

11 years ago
Comment on attachment 223042 [details] [diff] [review]
Crude fix

ugh, you really should figure out why elm has no parentNode - you probably have a reference to an element no longer in the DOM.

Check is ok for a temp fix though (0.6)
Attachment #223042 - Flags: review?(doronr) → review+
(Reporter)

Comment 5

11 years ago
Comment on attachment 223042 [details] [diff] [review]
Crude fix

something's wrong alright, but temp fix. for 0.6, please.
Attachment #223042 - Flags: review?(Olli.Pettay)

Comment 6

11 years ago
Comment on attachment 223042 [details] [diff] [review]
Crude fix

Could you put the whole
method inside CDATA.
& is just too ugly,
& is much better
With that r=me
Attachment #223042 - Flags: review?(Olli.Pettay) → review+
(Reporter)

Comment 7

11 years ago
Fixed on trunk w/smaug's comment fixed
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Reporter)

Updated

11 years ago
Blocks: 339062
(Reporter)

Comment 8

11 years ago
Filed follow up bug 339062.
(Reporter)

Updated

11 years ago
Keywords: fixed1.8.1
(Reporter)

Updated

11 years ago
Keywords: fixed1.8.0.5
(Reporter)

Updated

11 years ago
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.