Message to large number of recipients "hangs" mail

VERIFIED FIXED in M17

Status

MailNews Core
Backend
P3
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: gerv, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win95; U)
BuildID:    20000328

I recently received a message with 574 people in the To: field. I access my 
mailbox via IMAP. With that message in, Mail sits at the "Opening Folder..." 
stage for as long as you care to wait. Deleting the message reenables access to 
the folder. It doesn't hang as such, it just sits there thinking.

Reproducible: Always
Steps to Reproduce:
1. Send yourself such a message
2. Try and access your mailbox

Actual Results:  No access

Expected Results:  Access :-)

I will attach the mail message, although getting it back into the right place in 
a Moz install may be non-trivial. However, apart from the large number of 
recipients, there doesn't seem much odd about it.

It seems to have found some limitations in NS 4.x's HTML exporter though, as the 
export doesn't seem to have worked too well. I will attach as both HTML and TXT.

If you would like the message forwarding to a given mailbox, let me know.

Critical because if Moz was your only browser, a dodgy e-mail could deny you 
access to your mailbox.
(Reporter)

Comment 1

18 years ago
Created attachment 7056 [details]
html NS 4.x export of message
(Reporter)

Comment 2

18 years ago
Created attachment 7057 [details]
txt NS 4.7 export of message

Comment 3

18 years ago
Can you turn on IMAP logging and attach a log file?  
http://www.mozilla.org/quality/mailnews/tests/sea-mn-imap-interop.html#logging
(Assignee)

Comment 4

18 years ago
to be clear, we're talking about mozilla here, right,  not 4.7?

Comment 5

18 years ago
Yes. Take a look at the build ID reported.  I think the reporter is using 4.7 to 
export the msg since he can't access the message in 5.0.
(Reporter)

Comment 6

18 years ago
The attachment is the result of turning in IMAP logging, zapping profile, 
rebooting, importing NS 4.x profile (which is what I always do for my IMAP 
settings). I then used NS 4.7 to move the offending message back into my INBOX, 
and fired up Mail. It did the normal thing of getting stuck on "Opening 
Folder...". When I pressed STOP, it displayed every message apart from the dodgy 
one. However, selecting one of these for display resulted in getting stuck 
again. I then pressed STOP and quit Mail.

In both cases, I waited over a minute. Note that the message display pane didn't 
repaint during the time it was attempting to display the message - it contained 
whatever was in that area of screen before Mail, if you see what I mean.

Gerv
(Reporter)

Comment 7

18 years ago
Created attachment 7061 [details]
IMAP log of problem
(Assignee)

Comment 8

18 years ago
I'll take this - I thought I already had it. Maybe it's a dup.
Assignee: selmer → bienvenu

Comment 9

18 years ago
Marking M17.  If this is a beta2 stopper, please adjust.
Target Milestone: --- → M17

Comment 10

18 years ago
I'm also able to recreate this problem. Please see:
http://bugzilla.mozilla.org/show_bug.cgi?id=35153

My IMAP log file ends with:
1100[1bbe018]: tarkin.ost.tele.dk:S-INBOX:PARSER:Internal Syntax Error: %s: * 
38 FETCH (UID 6780 RFC822.SIZE 672 FLAGS (\Seen) ENVELOPE ("Fri, 17 Mar 2000 
15:58:20 +0100" "Den =?iso-8859-1?Q?V=E6ge

Running Win2k on build 2000040708

Updated

18 years ago
URL: None

Updated

18 years ago
QA Contact: lchiang → huang

Comment 11

18 years ago
*** Bug 35153 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

18 years ago
accepting
Status: NEW → ASSIGNED

Comment 13

18 years ago
Leaf - adding you to cc: list.  David thinks this is the bug that you're running 
into on your system.
(Assignee)

Comment 14

18 years ago
it looks to me like the server is never returning data when I request the 
envelope for this message with the netscape 4.x server.

Comment 15

18 years ago
I'm also able to reproduce this on Exchange:
Microsoft Exchange IMAP4rev1-server version 5.5.2232.11
(Assignee)

Comment 16

18 years ago
the log looks like it's from a UW server. So, if UW, MS Exchange, and Netscape 
4.x all generate the (null) response, maybe there's some problem in necko or 
we're supposed to be able to handle null responses?
(Assignee)

Comment 17

18 years ago
i tried entering the envelope command directly to our 4.x server, and I did get 
a response, so it doesn't look like a server problem. Looks like either necko or 
the imap code is not happy with the single 23K line that comes back. I don't 
know how it could be the imap code, but I'll look into it.
(Assignee)

Comment 18

18 years ago
looks like a bug in char * nsMsgLineStreamBuffer::ReadNextLine(nsIInputStream * 
aInputStream, PRUint32 &aNumBytesInLine, PRBool &aPauseForMoreData)

It doesn't handle the case of a line larger than the line buffer, which is 4K. I 
don't know why it doesn't just grow the buffer - I'll fix it.
(Assignee)

Comment 19

18 years ago
Created attachment 7514 [details] [diff] [review]
proposed fix
(Assignee)

Comment 20

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 21

18 years ago
Still not working in my 20000424.

Still getting this error on mail with many recipients:
1092[20ba4f0]: tarkin.ost.tele.dk:S-INBOX:PARSER:Internal Syntax Error: %s: * 48 
FETCH (UID 7592 RFC822.SIZE 2425 FLAGS (\Seen) ENVELOPE ("Thu, 22 Apr 1999 
21:25:27 -0700 (PDT)" "anyone want a sate

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 22

18 years ago
This now (2000428) WORKSFORME using the original problem e-mail.

Gerv

Comment 23

18 years ago
I'm still unable to check my mail with Mozilla because of this bug. I'm using 
2000042808 and the bug is still there. So no worksforme...:(
(Reporter)

Comment 24

18 years ago
Are you sure it's this bug you are seeing? It would only be this bug if you 
_could_ access your mail with Mozilla when you had moved the message(s) with 
lots of recipients out of your INBOX. If you still can't, then it's a different 
bug, and not this one ;-)

Gerv

Comment 25

18 years ago
After I moved all the mails with multiple recipients from my INBOX my IMAP log 
generates no more error. When I move them back, I get the error.

So it is this bug...:)

And it's the same error all the time: INBOX:PARSER:Internal Syntax Error

On of the mails it chokes on has 3 recipients...

Comment 26

18 years ago
Created attachment 8129 [details]
Mail with two recipients that mozilla cant read. Will give you "PARSER:Internal Syntax Error" in IMAP log
(Assignee)

Comment 27

18 years ago
it's not the same bug - it's a different bug. If what didn't use to work for 
gervase now works as the result of a code change, then this bug is fixed. Note 
that your problem message only has two recipients, more evidence that it's not 
the same bug.

Comment 28

18 years ago
Should I file another bugm since "my" bug renders using Mozilla Mail impossible. 
After I get the PARSER:Internal Syntax Error it's impossible to view any mails.
(Reporter)

Comment 29

18 years ago
Yes :-) Thanks.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 30

18 years ago
The new bug filed by Henrik is: 
http://bugzilla.mozilla.org/show_bug.cgi?id=37675

Comment 31

18 years ago
From Gervase's IMAP log, this bug is originally logged for UW IMAP server (not 
MS Exchange IMAP server)
David is right that this bug is different as bug 35153 (different as Henrik's 
MS Exchange IMAP server).
Gervase, since from 04-29 your comments that this bug was work for you after 
David fixed...actually this bug is also passed from my test....but I need to 
confirm with you -- Is this bug logged for "attaching" the mail message with the 
574 recipients(not sending to 574 recipients), right? If Yes. then please reply 
on this bug... so I can mark as verified for this bug now. Thanks.
(Reporter)

Comment 32

18 years ago
This bug was logged because it was impossible to open my INBOX when this message 
(with the large number of recipients) was in it. If I moved it out using other 
software, it all worked. Move it back in, and it stopped working.

Does that answer your question?

Gerv

Comment 33

18 years ago
I did notice from your log that your IMAP server directory was setting for Mail/ 
(Jeff fixed that bug recently)
I would like to know whether this problem also fixed with Mail/ directory from 
UW IMAP sever.
Can you try again by using the latest build with this original problem? Thanks.
(Reporter)

Comment 34

18 years ago
Sadly, I have since deleted the mail that was causing the problem (because this 
bug was marked FIXED, I thought I wouldn't need it). So I am not immediately 
able to reproduce the conditions which caused the problem.

Gerv

Comment 35

18 years ago
Verified on 07-24-09-M17 Win98 commercial build
I can read this message with large number of recipients without hang now. 
Marking as verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.