warning: "/*" within comment

RESOLVED FIXED in 3.12

Status

NSS
Libraries
P5
trivial
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
pk11obj.c:1143:4: warning: "/*" within comment
pk11obj.c:1152:17: warning: "/*" within comment
pk11obj.c:1162:7: warning: "/*" within comment

could this please be addressed? i know it's sample code, but perhaps

#undef SAMPLE_CODE
#ifdef SAMPLE_CODE
...
#endif

would be better, then the code would be recognized by syntax highlighters, the /* embedded in the code */ would be treated as a comment and the compiler would not complain about it.
Priority: -- → P5
Timeless, is this a coverity bug?
(Assignee)

Comment 2

11 years ago
i didn't tag it as such, i have to presume it isn't. the syntax of the output here implies i was using gcc i believe.
(Assignee)

Comment 3

11 years ago
Created attachment 241149 [details] [diff] [review]
replace outer comments w/ #if 0 block and make sure {}s match

this bug is something i see whenever i build on boffo, because the build process hangs (for a relatively long time) while signing the nss library. as a result, i'm likely to see this annoying warning and want to file a bug about it. or today, post a patch :).
Assignee: nobody → timeless
Status: UNCONFIRMED → ASSIGNED
Attachment #241149 - Flags: review?(nelson)
Comment on attachment 241149 [details] [diff] [review]
replace outer comments w/ #if 0 block and make sure {}s match

r=nelson for the trunk (only), provided the patch still applies cleanly.
Attachment #241149 - Flags: review?(nelson) → review+
(Assignee)

Comment 5

10 years ago
nelson@bolyard.com: i don't have commit privs (which is fairly annoying on its own given that i do touch the whole tree and play nicely by rules), would you please commit?
On trunk
new revision: 1.17; previous revision: 1.16
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.12
You need to log in before you can comment on or make changes to this bug.