Browser shows title of images on mouse over instead of the alternative text (alt )

RESOLVED DUPLICATE of bug 25537

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 25537
12 years ago
12 years ago

People

(Reporter: nls.pct, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

When I pass my mouse over the image of this link : http://www.siteduzero.com/uploaded_img/3/tutos/29/1.5.2.html it only show me the title of the image and not the alternative text, the image source is : <img src="68617761692e6a7067" alt="Photo de Hawaii" title="Ca fait envie hein ?" /> normallay it should show "Photo de Hawaii" but it shows "Ca fait envie hein ?" and when there is no title, it don't show nothing at all. 

Reproducible: Always

Steps to Reproduce:
1. Start this page http://www.siteduzero.com/uploaded_img/3/tutos/29/1.5.2.html
2. Pass the mouse on the image
3. Look the page source code
4. You'll see that the image don't show the alternative text but the title
5. If you wan't to be shure
6. Go on this page : http://www.siteduzero.com/uploaded_img/3/tutos/29/1.5.1.html
7. Look the source code
8. You'l see that there is an alt but it doesn't show nothing.
Actual Results:  
After I've seen that there was a problème so I wrote to you the beug.

Expected Results:  
The software should have shown me the alternative text instead of the title in the first case when I've passed my mouse over. In the second case it should have wrote me the alternative text when I passed my mouse over.

I change theme it didn't resolve the problème. I was using the noia theme and i took back the default theme.

Comment 1

12 years ago
The alternative text is just that: alternative to the image (to be displayed instead and not additionally). Firefox just adheres to the spec.

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.