image size specification is used for alt text too

RESOLVED DUPLICATE of bug 223764

Status

()

Core
Layout: Images
RESOLVED DUPLICATE of bug 223764
12 years ago
9 years ago

People

(Reporter: Jan Lana, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html><body>
<a href="link.html"><img src="nonexistent.gif" width="30" height="30" align="top" border="0" alt="IMG"></a><a href="link">baseline</a>
</body></html>

Reproducible: Always

Steps to Reproduce:
1. open the example in browser

Actual Results:  
"IMG" underline is too low

Expected Results:  
"IMG" and "baseline" underline should be in the same height


If you remove the width and height attributes or put a char between '..."IMG">' and '</a>', the problem does not occure.

Comment 1

12 years ago
Here with a trunk build and with Firefox 1.5, IMG is on the same line as baseline. So it just looks like "IMGbaseline".
Can you try with a official build from mozilla.org?
(Reporter)

Comment 2

12 years ago
Created attachment 221696 [details]
demonstration of the bug
(Reporter)

Comment 3

12 years ago
Comment on attachment 221696 [details]
demonstration of the bug

tested on Debian 'etch' x86
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060510 Minefield/3.0a1 - Build ID: 0000000000
WFM.
Assignee: jdunn → nobody

Comment 5

9 years ago
I can reproduce the result seen in the attached screenshot. This is an issue in Almost Standards Mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 223764
You need to log in before you can comment on or make changes to this bug.