If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Application switching (CMD+TAB or mouse-based) is broken, switching focus to Thunderbird main window horked

RESOLVED DUPLICATE of bug 337334

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 337334
12 years ago
12 years ago

People

(Reporter: Patrick, Assigned: Mark Mentovai)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
On a MAC using the CMD + TAB key allows you to switch between applications. Currently, when switchiing to Thunderbird, the main window does not get the focus.

Steps to reproduce
1. start Thunderbird
2. start Firefox
3. Press CMD+Tab

--> Thunderbird becomes the active application (visible by the appearence of its menu on the top of the screen), but the main window does not appear.

Pressing an additional CMD+` is needed to give focus to main window/make main window appear at all.

Maybe a patch for this bug could also address bug 318585?
(Reporter)

Comment 1

12 years ago
Also happens with Minefield. Moving to Core.
Reproducibility is not 100%.
Component: Mail Window Front End → Event Handling
Product: Thunderbird → Core
(Reporter)

Comment 2

12 years ago
Created attachment 221732 [details]
Sceenshot of redraw issue

One more observation:  Related or not, but i'm also having redraw issues with 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060510 Minefield/3.0a1

After application switching occassionally, much of Minefield is missing: (personal) toolbars, address bar, the actual page etc.
Patrick, can you find out what the regression range is?
(Reporter)

Comment 4

12 years ago
I think this may've been caused by Darin's thread changes from that day. Seems like some of the follow-up checkins (bug 337824, bug bug 337550, bug 337481) also fixed this.

Marking as such --> fixed by checkin for (probably) bug 337824.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 5

12 years ago
I'm still experiencing this, sometimes, with

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060521 Minefield/3.0a1
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> I'm still experiencing this, sometimes, with
> 
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060521
> Minefield/3.0a1
 

Reopening based on comment 5
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mark, are you aware of this bug?
(Assignee)

Comment 8

12 years ago
I wasn't, but I am now.
Assignee: mscott → mark
Status: REOPENED → NEW
(Assignee)

Comment 9

12 years ago
As I suspected, this occurs when you hit the new icon decoder code from bug 335723.  It's a slight variation on bug 337334.

*** This bug has been marked as a duplicate of 337334 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.