Last Comment Bug 337607 - [@ nsEventStateManager::HandleAccessKey]
: [@ nsEventStateManager::HandleAccessKey]
Status: RESOLVED FIXED
: crash, fixed1.8.0.7, fixed1.8.1, topcrash
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (vacation Aug 25-28)
: Hixie (not reading bugmail)
Mentors:
http://bonsai.mozilla.org/cvsblame.cg...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 09:08 PDT by timeless
Modified: 2006-08-16 01:38 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed patch (2.32 KB, patch)
2006-06-29 09:28 PDT, Olli Pettay [:smaug] (vacation Aug 25-28)
bzbarsky: review+
bzbarsky: superreview+
dveditz: approval1.8.0.7+
Details | Diff | Splinter Review
for 1.8 (2.04 KB, patch)
2006-07-22 11:47 PDT, Olli Pettay [:smaug] (vacation Aug 25-28)
mbeltzner: approval1.8.1+
Details | Diff | Splinter Review

Description timeless 2006-05-11 09:08:00 PDT
Incident ID: 18563830
Stack Signature	nsEventStateManager::HandleAccessKey c6b95f66
Product ID	FirefoxTrunk
Build ID	2006050405
Trigger Time	2006-05-11 06:46:48.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (00282bf1)
URL visited	<a href='http://landfill.mozilla.org/ryl/random.html'>http://landfill.mozilla.org/ryl/random.html</a>
User Comments	trying to crash firefox. i have to do something while i wait for trees to burn
Since Last Crash	97041 sec
Total Uptime	282921 sec
Trigger Reason	Access violation
Source File, Line No.	c:\builds\tinderbox\fx-trunk-cairo\winnt_5.2_depend\mozilla\content\events\src\nseventstatemanager.cpp, line 1077
Stack Trace 	
nsEventStateManager::HandleAccessKey   
nsDocLoader::AddRef  

The url is a guess at what could possibly be going wrong. note that i was probably actively loading new windows so it's possible my window changed or something.
Comment 1 Olli Pettay [:smaug] (vacation Aug 25-28) 2006-06-29 09:28:30 PDT
Created attachment 227557 [details] [diff] [review]
proposed patch

Changing assertion to if (). (I think) this crash may happen if window is closed or presshell otherwise destroyed before keypress.  And anyway, I see no reason for 
the assertions in this case. Simple if () is enough.
Ofc, I can't reproduce the crash atm, but afaik it is still possible to crash.
And this patch should not cause any harm :)
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2006-07-22 09:36:09 PDT
This is also quite a 'popular' crash on the 1.8.1 branch (ranked 3rd, as I write this):
http://talkback-public.mozilla.org/reports/firefox/FF2x/index.html

I can easily reproduce the crash on latest build Firefox2 branch with this url:
http://www.mountyhall.com/mountyhall/Forum
and then quickly going back and forth in history, using alt+arrow keys left and right.

Olli, you want to ask approval1.8.1? on the patch?
I hope/expect this patch would fix it.
Comment 3 Olli Pettay [:smaug] (vacation Aug 25-28) 2006-07-22 09:56:27 PDT
I'll test first. But probably this could go into 1.8 and 1.8.0
Comment 4 Olli Pettay [:smaug] (vacation Aug 25-28) 2006-07-22 11:47:38 PDT
Created attachment 230277 [details] [diff] [review]
for 1.8

This fixes the crash also on 1.8
Comment 5 Olli Pettay [:smaug] (vacation Aug 25-28) 2006-07-22 11:50:02 PDT
Comment on attachment 227557 [details] [diff] [review]
proposed patch

And this patch applies almost cleanly to 1.8.0 branch.
Comment 6 Mike Beltzner [:beltzner, not reading bugmail] 2006-07-24 10:38:34 PDT
Comment on attachment 230277 [details] [diff] [review]
for 1.8

a=drivers. Please go ahead and land this on the branch.
Comment 7 Olli Pettay [:smaug] (vacation Aug 25-28) 2006-07-28 06:01:29 PDT
This was checked in to 1.8.1, so remowing blocking1.8.1? flag
Comment 8 Daniel Veditz [:dveditz] 2006-08-15 15:25:09 PDT
Comment on attachment 227557 [details] [diff] [review]
proposed patch

approved for 1.8.0 branch, a=dveditz for drivers

Note You need to log in before you can comment on or make changes to this bug.