Closed Bug 337661 Opened 18 years ago Closed 18 years ago

LDAP user login failure: Can't locate object method "realname" via package "Bugzilla::User"

Categories

(Bugzilla :: User Accounts, defect, P1)

2.23

Tracking

()

RESOLVED FIXED
Bugzilla 3.0

People

(Reporter: bugzilla, Assigned: mkanat)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: 

I ran into this testing mkanat's fix for bug 300410

Prior to this patch, authentication was working fine. I had logged in as an LDAP 
user, run queries etc. I applied v7.1 of the patch (now in HEAD) which caused any further access attempts ]with this ldap user to fail.

Reproducible: Always

Steps to Reproduce:
1. Configure bugzilla to authenticate against an active directory domain via LDAP
2. Login as an ldap user
3. Apply fix for bug 300410
4. Refresh the page.
Actual Results:  
[Thu May 11 16:39:01 2006] [error] [client X.X.X.X] [Thu May 11 16:39:01 2006]
index.cgi: Can't locate object method "realname" via package "Bugzilla::User"
at Bugzilla/Auth/Verify.pm line 112, <DATA> line 283., referer:
http://somebugzillahost/index.cgi?GoAheadAndLogIn=1



Expected Results:  
Successful login.
Version: unspecified → 2.23
Assignee: user-accounts → mkanat
Attached patch v1Splinter Review
Oh, hahahaha. That's because there's no such method! Silly me. :-)

Hey Mark, could you apply this patch and then tell me if you get any further?

I appreciate the help--Bugzilla LDAP auth will work because of you. :-D
Attachment #221786 - Flags: review?(LpSolit)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Linux → All
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.24
Your patch works! I'm now able to log in as an ldap user again.
Comment on attachment 221786 [details] [diff] [review]
v1

r=LpSolit
Attachment #221786 - Flags: review?(LpSolit) → review+
Flags: approval?
Depends on: 300410
Flags: approval? → approval+
Checking in Bugzilla/Auth/Verify.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Auth/Verify.pm,v  <--  Verify.pm
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.