Command-backtick (Cmd-`) does not switch windows unless held down

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2

Command-backtick is the Mac OS X keyboard shortcut to switch between windows within the foreground app. In Firefox, I am unable to switch windows using that method, unless I hold down the key for over 2 seconds. Holding down the key combination causes Firefox to switch rapidly between all open windows as keyboard repeat kicks in.

Reproducible: Always

Steps to Reproduce:
1. Open at least two windows in Firefox.
2. Press and release cmd-`.
3. Press and hold cmd-`.

Actual Results:  
Does nothing in step 2. Cycles rapidly in step 3.

Expected Results:  
Should switch to the next Firefox window in step 2.

I have experienced this problem in both Firefox 1.5 and BonEcho Alpha 2.

Cmd-` behaves as expected in most other applications, including all applications from Apple and Camino.

I don't know if it's at all related, but I am running this on a "Dual USB" iBook with a 600MHz G3 Processor and 384MB of RAM. It is however running a fairly recent clean install of Mac OS X 10.4 without Application Enhancer or any other software which should interfere with program UI.

Comment 1

13 years ago
works for me in Mac OS X 10.23.8, on a 300 MHz iBook

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2
I noticed this same issue when upgrading to FF2.0b2 this morning.  But it's working fine with a new profile.  Finally tracked it down to Firebug 0.4; disabling this extension allowed Cmd-` to work as expected.

It seems that the Firebug command "Clear Console" is set to the key combo Cmd-~ (tilde).  Maybe the key handlers aren't recognizing the difference between Cmd-` and Cmd-~?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

12 years ago
This problem still occurs for me in Beta 2 with a new profile.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Comment 4

12 years ago
OSX 10.4.7 on Intel MacBook, FF2.0b2 with FireBug installed needed to have COmmand+` held to scroll (though was unusable due to the rapid nature of the window switching.)

Unistalling FireBug restores the functionality. This conflict did not happen for me in FF1.5.0.6 with Firebug installed.

Comment 5

12 years ago
I can repro on my TiBook, running OS X 10.4.7 - Firefox 2.0b2.  

Uninstalling Firebug 1.4 fixes the problem.

Re-Installing Firebug however, does not.

Comment 6

12 years ago
Is this or is this not a regression from 1.5.0.6+FireBug?

Comment 0 seems to say it's not, comment 2 seems to say it is.
(Reporter)

Comment 7

12 years ago
I reported the original bug, and I have never used Firebug.

The bugs may be related, but I have no way of confirming that.

The behaviour experienced by the Firebug users sounds identical to the problem I have with a clean install/profile, however.
(In reply to comment #6)
> Is this or is this not a regression from 1.5.0.6+FireBug?
> 
> Comment 0 seems to say it's not, comment 2 seems to say it is.

It's definitely a regression from 1.5.0.6+FireBug for me, I reported this bug about a month ago (didn't find this one at the time), then marked it invalid after I figured out it was FireBug, and reported it in the FireBug forums.  Neither my post a month ago nor the one referencing this bug have been replied to yet there.

It could be some other extension other than FireBug for the reporter though...

This might be the key:

(In reply to comment #2)
> It seems that the Firebug command "Clear Console" is set to the key combo
> Cmd-~ (tilde).  Maybe the key handlers aren't recognizing the difference
> between Cmd-` and Cmd-~?

Have there been such changes since 1.5.0.6 in the key handlers?
(Reporter)

Comment 9

12 years ago
(In reply to comment #8)
> It could be some other extension other than FireBug for the reporter though...

I have no Firefox extensions, and have gone so far as to completely remove the ~/Library/Application Support/Firefox folder where the profiles are stored, disable all plugins, and to try using another user account.

> This might be the key:
> 
> (In reply to comment #2)
> > It seems that the Firebug command "Clear Console" is set to the key combo
> > Cmd-~ (tilde).  Maybe the key handlers aren't recognizing the difference
> > between Cmd-` and Cmd-~?
> 
> Have there been such changes since 1.5.0.6 in the key handlers?
> 

This gave me an idea though. The key sequence that switches between windows is configurable in System Preferences. If I change the key to something that is not in use, such as cmd-\, then I get the right behaviour for window switching. If I change it to something that Firefox does use, such as cmd-= (Increase Font Size), Firefox catches the initial key press, but if I hold the key down, Firefox will then rotate rapidly through each open window as with cmd-`.

This suggests to me that something in Firefox is catching the key press for cmd-`.

Since most people don't seem to be having this problem, I would be willing to believe it's something wrong with my system, but problem with that is I'm using a freshly downloaded copy of Firefox 2.0b2 and all my other apps behave correctly.
(In reply to comment #9)
> I have no Firefox extensions, and have gone so far as to completely remove the
> ~/Library/Application Support/Firefox folder where the profiles are stored,
> disable all plugins, and to try using another user account.

I was going to ask if you'd gottten ~/Library/Preferences/org.mozilla.firefox.plist as well, but changing user accounts should have dealt with that...

Comment 11

12 years ago
I have the same problem with a fresh installa of firefox 1.5.0.7 on intel Mac OSx 10.4.7.
I was previously usin 10.4.6 without the bug, so I must suppose it's a problem witht he latest version of the browser, and since changing the system key for window switching everything works well it must certainly be the browser that listen for that particolar kayboard shortcut.

anyone has any idea about what could be the real cause?

Comment 12

12 years ago
I was having this problem in Firefox 2.0b2. Disabling Firebug 0.4 fixed the problem, as did re-assigning Firebug's Clear command (using Keyconfig) from Command-~ to something else (Command-Shift-x, for example).

In other words, it definitely appears to be a key conflict with Firebug, at least in my case.

Comment 13

12 years ago
(In reply to comment #12)
> I was having this problem in Firefox 2.0b2. Disabling Firebug 0.4 fixed the
> problem, as did re-assigning Firebug's Clear command (using Keyconfig) from
> Command-~ to something else (Command-Shift-x, for example).
> 
> In other words, it definitely appears to be a key conflict with Firebug, at
> least in my case.
> 

It can be true for firefox 2.0b2, but I checked a clean install of firefox 1.5.0.7 and did get the same result... So it definitely isn't produced by firebug in our case.

Comment 14

12 years ago
After some research I've been capable to fix it for me...
First of all the problem wasn't due to firefox himself, but by the "services" feature of Mac OSx: 2 different other applications where registering the "command - <" (I'm using italian keyboard) shortcut as service command, overriding windows switching in firefox.

What I asked myself was "why only in firefox"? Well, Mac OSX services seems to act differently based on the sort of content the applications are exposing to services themselves, so these aprticular application services where "active" only in firefox (and maybe other apps I don't use).

I solved everything by running Services Scrubber (http://www.petermaurer.de/nasi.php?section=servicescrubber) a very nice donationware program able to modify the services menu.

That's all folks, if other people with the problem can confirm this was the cause we can mark the bug as solved ;-)

Jules


(In reply to comment #13)
> (In reply to comment #12)
> > I was having this problem in Firefox 2.0b2. Disabling Firebug 0.4 fixed the
> > problem, as did re-assigning Firebug's Clear command (using Keyconfig) from
> > Command-~ to something else (Command-Shift-x, for example).
> > 
> > In other words, it definitely appears to be a key conflict with Firebug, at
> > least in my case.
> > 
> 
> It can be true for firefox 2.0b2, but I checked a clean install of firefox
> 1.5.0.7 and did get the same result... So it definitely isn't produced by
> firebug in our case.
> 

Comment 15

12 years ago
I've released a new version of FireBug which removes the key binding to Cmd-~.  Apologies for taking so long to fix this, and for any annoyance in the mean time.

You can wait for addons.mozilla.org to auto-update you or install the update now from here: http://www.joehewitt.com/software/firebug/

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

11 years ago
Sorry, somehow I originally missed comment #14. Indeed using service scrubber to remove a service bound to command-~ (command-shift-`) solved my problem.

It is still unclear to me why this was causing a problem in Firefox for command-`, when the service was bound to command-~ (command-shift-`), especially since, to the best of my knowledge, Firefox cannot use that or any other application menu service. Nor did that binding cause any problems in any other app, regardless of whether or not the app could use it. (In my case, it was a multilingual dictionary <http://homepage.mac.com/andrewlindesay/le/page_wordlookup.html>, which could be used in TextEdit.app, for example.) Testing just now, it seems as if it also affects MS Word 2004, which is also not services-aware.

To me, it would seem as if this is still a small bug, since a different (albeit closely-related) shortcut was interfering with a default OSX shortcut, and only in Firefox (and MS Word.) However, since there is a simple known workaround, and it only affects the handful of people who have a service bound to cmd-~, I'm not inclined to complain too much if it goes unfixed.
You need to log in before you can comment on or make changes to this bug.