Last Comment Bug 337875 - set showInConsole to true for Firefox debug builds
: set showInConsole to true for Firefox debug builds
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Firefox 3 alpha1
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
:
Mentors:
: 435512 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-13 17:20 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2010-12-15 06:44 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
set showInConsole to true for Firefox debug builds (2.27 KB, patch)
2006-05-13 17:21 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
benjamin: review-
Details | Diff | Splinter Review
Try this (896 bytes, patch)
2006-05-16 05:19 PDT, Benjamin Smedberg [:bsmedberg]
no flags Details | Diff | Splinter Review
Try this, rev. 2 [fixed on trunk] (4.13 KB, patch)
2006-05-16 06:47 PDT, Benjamin Smedberg [:bsmedberg]
gavin.sharp: review+
Details | Diff | Splinter Review
set showInConsole to true for Firefox debug builds, v2 (1.37 KB, patch)
2006-05-16 20:37 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
benjamin: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2006-05-13 17:20:24 PDT
Splitting this off from bug 248528 which was originally about strict warnings.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-05-13 17:21:41 PDT
Created attachment 221936 [details] [diff] [review]
set showInConsole to true for Firefox debug builds
Comment 2 Benjamin Smedberg [:bsmedberg] 2006-05-16 03:22:33 PDT
Comment on attachment 221936 [details] [diff] [review]
set showInConsole to true for Firefox debug builds

It shouldn't be necessary to mess with -DDEBUG... why isn't that in DEFINES by default in debug builds?

We should only be defining DEBUG in debug builds (-DDEBUG= is wrong), and then using #ifdef DEBUG
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-05-16 05:04:09 PDT
(In reply to comment #2)
> (From update of attachment 221936 [details] [diff] [review] [edit])
> It shouldn't be necessary to mess with -DDEBUG... why isn't that in DEFINES by
> default in debug builds?

I don't know. I assumed it was due to how the preprocessor was invoked for the prefs files. Just "#ifdef DEBUG" does not work (is always false). See also bug 248528 comment 14.
Comment 4 Benjamin Smedberg [:bsmedberg] 2006-05-16 05:19:43 PDT
Created attachment 222166 [details] [diff] [review]
Try this
Comment 5 Benjamin Smedberg [:bsmedberg] 2006-05-16 06:47:39 PDT
Created attachment 222174 [details] [diff] [review]
Try this, rev. 2 [fixed on trunk]
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-05-16 20:37:09 PDT
Created attachment 222302 [details] [diff] [review]
set showInConsole to true for Firefox debug builds, v2

this works now
Comment 7 Leon Sha 2006-05-17 04:05:30 PDT
This check in caused build failed to me.
I think the problem here is -DDEBUG_leon.sha.
There is a "." in my user name, that cause the problem.

________________________________________________________________________
gmake[1]: Entering directory `/export/home/leon.sha/uild/firefox/build0517/mozilla/netwerk/base/public'
if test ! -d ../../../dist/bin/greprefs; then /export/home/leon.sha/uild/firefox/build0517/mozilla/config/nsinstall -D ../../../dist/bin/greprefs; fi
set -e;   \
for i in ./security-prefs.js; \
do /usr/bin/perl ../../../config/preprocessor.pl  -DOSTYPE=\"SunOS5\" -DOSARCH=\"SunOS\" -DBUILD_ID=0000000000 -DIMPL_NS_NET -DMOZILLA_VERSION=\"1.9a1\" -DMOZILLA_VERSION_U=1.9a1 -DSOLARIS=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_LANGINFO_CODESET=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DHAVE_I18N_LC_MESSAGES=1 -DMOZ_EMBEDDING_LEVEL_DEFAULT=1 -DMOZ_EMBEDDING_LEVEL_BASIC=1 -DMOZ_EMBEDDING_LEVEL_MINIMAL=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_XUL_APP=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk2\" -DMOZ_WIDGET_GTK2=1 -DMOZ_ENABLE_XREMOTE=1 -DMOZ_X11=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_ENABLE_XFT=1 -DMOZ_ENABLE_GNOMEUI=1 -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_NO_XPCOM_OBSOLETE=1 -DMOZ_XTF=1 -DMOZ_MATHML=1 -DMOZ_ENABLE_CANVAS=1 -DMOZ_SVG=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_PLACES=1 -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_LOGGING=1 -DMOZ_USER_DIR=\".mozilla\" -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_SYS_INT_TYPES_H=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZ_ACCESSIBILITY_ATK=1 -DMOZILLA_LOCALE_VERSION=\"1.9a1\" -DMOZILLA_REGION_VERSION=\"1.9a1\" -DMOZILLA_SKIN_VERSION=\"1.8\"  -DDEBUG -D_DEBUG -DDEBUG_leon.sha $i > ../../../dist/bin/greprefs/`basename $i`; \
done
../../../config/preprocessor.pl: invalid argument to -D: DEBUG_leon.sha
gmake[1]: *** [libs] Error 2
gmake[1]: Leaving directory `/export/home/leon.sha/uild/firefox/build0517/mozilla/netwerk/base/public'
gmake: *** [all] Error 2
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-05-17 08:40:13 PDT
(In reply to comment #7)
> This check in caused build failed to me.
> I think the problem here is -DDEBUG_leon.sha.
> There is a "." in my user name, that cause the problem.

I filed bug 338305 for this.
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-05-20 20:04:55 PDT
mozilla/browser/app/profile/firefox.js 	1.113
Comment 10 Nickolay_Ponomarev 2006-05-21 10:08:55 PDT
On my other machine I have a non-English Windows user name (even though I know it causes lots of problems). I believe this check in makes the build fail for me with

"not a valid variable name: 'DEBUG_Љолп'" from preprocessor.pl
Comment 11 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2010-12-15 06:44:17 PST
*** Bug 435512 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.