In Multiweek, multiday events have start time on every day

RESOLVED DUPLICATE of bug 199732

Status

Calendar
Calendar Views
RESOLVED DUPLICATE of bug 199732
12 years ago
9 years ago

People

(Reporter: xiang17, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2

In the Multiweek-View a multiday event ist shown on each day with its start-time. But the start-time belongs only to the first day, the last day should show "until end-time" an the days in the middle should be shown as "all day". This is the way, a multiday event is displayed in week-view.

Reproducible: Always

Steps to Reproduce:
1. Create an event starting at 9:00 and ending 3 days later at 11:00.

2. select multiweek-view
Actual Results:  
You will see 9:00 on all days.


Expected Results:  
It should be "9:00" on the first, "all day" on the following and "until 11:00" on the last.
Assignee: nobody → base
Status: UNCONFIRMED → NEW
Component: General → Base
Ever confirmed: true
OS: Windows XP → All
QA Contact: general → base
Hardware: PC → All
Version: unspecified → Trunk
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody
Component: Internal Components → Calendar Views
QA Contact: base → views

Comment 2

11 years ago
http://img143.imageshack.us/img143/1561/calendarvi2.png

The bug in action in Lightning 0.3 in Thunderbird 1.5.0.7.

Comment 3

11 years ago
As expected, it also happens in Month View and also in Sunbird.

It is quite annoying for events that happen during the night and start before midnight and end at 01:00 for example. They appear as if they happen the next day again.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 199732
You need to log in before you can comment on or make changes to this bug.