Firefox crashes trying to load large image width="14929" height="526"

RESOLVED DUPLICATE of bug 210931

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 210931
12 years ago
12 years ago

People

(Reporter: Eric Cartman, Unassigned)

Tracking

({crash})

1.5.0.x Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3


Although this page also crashes my kde browser, I was able to get the source
(below) and a copy of the image file. The image file is 1850451 bytes. I 
verified that the image is not corrupted. Attempts to load it at a file
produced the same crash (no feedback reporter). 

This problem does not appear in Windows XP version
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3)


<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>Paris by night</title>
<bgsound src="Paris/souslecieldeparis.mid" loop="-1">
</head>

<body>

<p><i><font color="#993300">Cliquez sur la flèche en bas à droite pour faire
défiler Paris sous vos yeux... </font></i></p>

<p><i><font color="#993300">Cette merveilleuse photo est de Arnaud Frich&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
http://www.arnaudfrichphoto.com </font></i></p>

<p><img border="0" src="Paris/parisbynight.jpg" width="14929" height="526"></p>

</body>

</html>


Reproducible: Always

Steps to Reproduce:
1. navigate to http://framboise781.free.fr/Paris.htm
2.
3.

Actual Results:  
instant death

Expected Results:  
display panorama
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060517 Minefield/3.0a1 - Build ID: 0000000000
WFM.
Can you post a Talkback ID here please? (http://kb.mozillazine.org/Talkback)

Comment 2

12 years ago
Start Firefox from within a terminal and paste what output you see (if any) when it crashes.
Severity: normal → critical
Keywords: crash
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 3

12 years ago
[10:16 raven] /usr/local/firefox/firefox
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 15738 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)



[10:16 raven] /usr/local/firefox/firefox --sync
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 34573 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
(Reporter)

Comment 4

12 years ago
(In reply to comment #1)
> Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060517
> Minefield/3.0a1 - Build ID: 0000000000
> WFM.
> Can you post a Talkback ID here please? (http://kb.mozillazine.org/Talkback)
> 

Talkback does not appear and shows no incidents when invoked manually.

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 210931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.