Closed Bug 338337 Opened 15 years ago Closed 15 years ago

Update DHTML Accessibility roles

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: pilgrim, Assigned: aaronlev)

References

(Blocks 1 open bug, )

Details

(Keywords: access, fixed1.8.1, Whiteboard: Used by screen readers and GOK only. Updates/fixes roles & relations. Low risk. For a major feature (DHTML a11y). No API or l10n changes.)

Attachments

(2 files, 2 obsolete files)

New draft of DHTML Accessibility role taxonomy.  Need to check for changes and update gWAIRoleMap as needed.

http://lxr.mozilla.org/seamonkey/source/accessible/src/base/nsAccessible.cpp#1640
New properties as well. We have to decide whether it's worth updating the Firefox support until we have something approaching a stable spec.
States/properties as well
Assignee: pilgrim → aaronleventhal
Blocks: aria
Target Milestone: --- → Firefox 3
Version: 2.0 Branch → Trunk
No longer blocks: fox2access
Need to add option, select as roles.
Blocks: fox2access
Attachment #229968 - Flags: review?(pilgrim)
Attachment #229968 - Flags: review?(pilgrim)
Attachment #229980 - Flags: review?(pilgrim)
Attachment #229968 - Attachment is obsolete: true
Component: Disability Access → Disability Access APIs
Flags: review?(pilgrim)
Product: Firefox → Core
Target Milestone: Firefox 3 → ---
Flags: blocking1.8.1?
Whiteboard: Updates/fixes roles & relations. Low risk. For a major feature (DHTML a11y). No API or l10n changes.
given the question in comment 1, and the lack of clarity as to whether this is a stable spec, not going to block on this.
Flags: blocking1.8.1? → blocking1.8.1-
Attachment #229980 - Flags: review?(pilgrim)
Attachment #229980 - Flags: review?(pilgrim) → review+
It's worth harmonizing with the current spec because it does not break backwards compatibility and will allow authors to experiment with the new capabilities. Especially important for AJAX apps.
Comment on attachment 229980 [details] [diff] [review]
Update both roles and relations, and fix some issues with relations

I'll add a comment that explains that the max depth is an optimization for labels and desriptions, which we believe will be relatively nearby their controls in the DOM.
Attachment #229980 - Flags: superreview?(neil)
Attachment #229980 - Flags: superreview?(neil) → superreview?(bzbarsky)
Attachment #229980 - Flags: superreview?(bzbarsky) → superreview?(tor)
Attachment #229980 - Attachment is obsolete: true
Attachment #229996 - Flags: superreview?
Attachment #229980 - Flags: superreview?(tor)
Attachment #229996 - Flags: superreview? → superreview?(tor)
Attachment #229996 - Flags: superreview?(tor) → superreview+
Attachment #229996 - Flags: approval1.8.1?
Whiteboard: Updates/fixes roles & relations. Low risk. For a major feature (DHTML a11y). No API or l10n changes. → Used by screen readers and GOK only. Updates/fixes roles & relations. Low risk. For a major feature (DHTML a11y). No API or l10n changes.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
This patch seems non-trivial, so I worry about regressions at this stage of the release.  I'm concerned about the removal of some of the atoms.  Won't that impact people who are already depending on those atoms?  Or, were those atoms never implemented?  Can you give us more to go on here, so we understand the risk / reward trade-offs.  Thanks!
(In reply to comment #11)
> This patch seems non-trivial, so I worry about regressions at this stage of 
> the release.
> I'm concerned about the removal of some of the atoms.  Won't that
> impact people who are already depending on those atoms?  Or, were those atoms
> never implemented?

The new roles and relations we are adding certainly won't cause regressions. 
The only thing removed is "icon", which is not part of the evolving standard at all, and never was. Not sure how it got in there. In any case, no screen readers or assistive tech actually make use of "icon".

The only other changes are for description for, label for and labelled by. There were some obvious mistakes in that code. I was careful to test those changes.

For the most part, this code is just 1) additions to the role table, 2) fixing errors in the above mention relations, 3) moving the reverse relation finding intelligence for reuse purposes, 4) using that code for new relations

The benefit of those patches is that we will correct and fill out our support for roles and relations, and this is a critical thing to do as we try to get industry adoption for DHTML accessibility. The controlledby/controllerfor relations are especially important for AJAX applications, which is really a new area we're looking at. A live region's content can be controlled by a widget. Thus, when the widget has focus and the liveregion changes, a screen reader knows that the changes are related to that widget.

Flowsto and flowsfrom are not necessarily crucial at this point, but the way I implemented the patch it made sense to put them in at the same time.
Comment on attachment 229996 [details] [diff] [review]
1) Null check before CallQI, 2) remove magic number of 5000

a=drivers. Please go ahead and land this on the branch.
Attachment #229996 - Flags: approval1.8.1? → approval1.8.1+
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.