Firefox does not shut down when closing the last window

RESOLVED DUPLICATE of bug 337648

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 337648
12 years ago
10 years ago

People

(Reporter: Dennis Jacobfeuerborn, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060516 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060516 Minefield/3.0a1

When I close the last Firefox window the firefox-bin process doesn't quit. When I do a kill on the process and restart Firefox the Talkback window appears. I submitted the following Talkback: TB18802400M

Reproducible: Always




OS:Fedora Core release 5.89 (Rawhide)
(Reporter)

Updated

12 years ago
Flags: blocking1.9a1?
Version: unspecified → Trunk
How long did you wait for the process to end?
(Reporter)

Comment 2

12 years ago
I waited for several minutes. After some experimentation I found the following:

This occurs on all nightly builds after the 10th of May (checkin for bug 326273 ?) but not in the build before. What triggers this is a crash in the Nightly Tester Tools extension version 1.0.3 when closing Firefox. When I disable this extension everything is fine. When I enable it Firefox hangs on shutdown. When I enable it but disable the Talkback extension Firefox segfaults on shutdown.
You say Firefox segfaults if Talkback isn't enabled but that extension is? Could you build with debug symbols and get a backtrace?
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060517 Minefield/3.0a1 - Build ID: 0000000000
Confirmed, but I don't have the Nightly Tester Tools extension installed.
Status: UNCONFIRMED → NEW
Component: General → Startup and Profile System
Ever confirmed: true
(Reporter)

Comment 5

12 years ago
I think the Nightly Tester Tools extension only serves as a catalyst in this case and that basically anything that causes Firefox to crash on shutdown will trigger the real problem which is the hanging of the Talkback extension.

When I attach gdb to the process (which is a non-debug build) I see Talkback on the callstack so it gets started but then apparently so confused that it locks up. Could this be some sort of race condition in which the threadmanager tries to shutdown threads at the same time as Talkback tries to gather whatever information it needs for its reports from them?
This is almost certainly caused by Nightly Tester Tools and a workaround for that extension can be seen at: http://users.blueprintit.co.uk/~dave/web/firefox/nightly/linuxcrash.html

The actual cause, to my best estimation is basically the same as bug 337648 though while it seems to only be an assertion on Windows, it is actually causing problems on Linux.

Essentially NTT uses some objects on a background thread, then the garbage collector cleans them up in a different thread.

For info I have some extra talkback incidents, though they are all pretty much the same:

TB19037388W
TB19037360Q
TB19037339Z
TB19037319G
TB19037215G

The hanging only started since bug 326273 but the actual problem existed before then.
Cleaning things up via GC on the wrong threads is bad.  :(  I _know_ we have bugs on that, though.
Blocks: 326273
QA Contact: general → startup

Comment 8

12 years ago
So, can this bug be closed now that the actual cause is known to be with the nightly tester tools?
Well I think this is Nightly Tester Tools exposing a problem with threading in Mozilla. If those are already filed then this can just be duped there.

Updated

11 years ago
Flags: blocking1.9a1?

Comment 10

10 years ago
Dennis appears to be gone.
I never see a hang with NTT - using trunk or branch.
NTT was changed long ago to avoid using threading since it seems to cause so much problems. I think this is basically just bug 337648 though.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337648
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.