hidden column content of columns in event list if column is ahead Title column

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Jan Hutaø, Unassigned)

Tracking

Sunbird 0.3a2
x86
All

Details

(Reporter)

Description

12 years ago
User-Agent:       Opera/8.54 (X11; Linux i686; U; en)
Build Identifier: Sunbird 0.3 alpha2 (from ftp://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/releases/0.3a2/sunbird-0.3a2.en-US.win32.zip)

When i move any column (or more) ahead of Title column (in event-list, above of calendar), then content of the column is not visible.

Reproducible: Always

Steps to Reproduce:
1. clear default install
2. push any column to the left, in front of the Title column

Actual Results:  
I can NOT see content of the column

Expected Results:  
I can see content of the column
confirmed in 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060517 Mozilla Sunbird/0.3a2+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Additional information:

1. The column moved before 'Title' column is no longer available in the show-hide-restore-column menu of the header row. After moving back the column is shown in this menu again.

2. Clicking on the header row of the moved column to sort content produces the following JavaScript errors:

Error: col has no properties 
Source File: chrome://calendar/content/unifinder.js Line: 472

Error: uncaught exception: [Exception... "'[JavaScript Error: "col has no properties" {file: "chrome://calendar/content/unifinder.js" line: 472}]' when calling method: [nsITreeView::cycleHeader]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: onxblclick :: line 920"  data: yes]
I see the same behavior in Thunderbird 3.0a1 (20060517) and Minefield 3.0a1 (20060518) so this i a Core problem and not Sunbird only.
I see the same error in Sunbird 0.2+ (20050831) - looks like this problem is rather old.
Note to myself: Retest after Bug 330236 has been checked in.
This ought to be fixed by the check in for Bug 330236 and Bug 330170. 

Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060521 Mozilla Sunbird/0.3a2+ this works for me now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
OS: Windows XP → All
Resolution: --- → WORKSFORME
Version: unspecified → Sunbird 0.3a2
You need to log in before you can comment on or make changes to this bug.