Literal tabs or newlines break text rendering

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: kherron+mozilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
TB has a bug (bug 271312) where message subjects containing embedded newlines and tabs are displayed in the message list pane with the newlines & tabs intact. The exact effect of the bug depends on the text-rendering system in use. For example using gtk2 on my debian system the tabs display as a square enclosing the digits "0009".

Using a current (20060517) build of TB with cairo-gtk2, it seems that encountering one of these subject lines completely breaks text rendering with that font. For example, unread messages are normally displayed in bold. When the cairo-gtk2 TB tries to display an unread message subject containing a newline/tab, that line of the message list pane is left blank, and TB can't draw characters using that font anywhere else. If I toggle the message to "read" which draws it in a normal font, suddenly TB can't draw normal text either. If I delete the message (so it's drawn with a strikethru) the strikethru appears but not the text.

This effect isn't confined to the message list pane. It affects the entire gui. My "normal" font for the message pane happens to be the same font used for TB's menus and button legends. After trying to display a wrapped message subject for a "read" message, the GUI menu text and button labels also disappear the next time they're painted.

My TB build is a debug build and it doesn't print any unusual messages while this is going on.

Steps to reproduce:

1) Build thunderbird using cairo-gtk2.

2) Start TB and enter a mailbox containing a message with a "wrapped" subject (containing an embedded newline & tab).

3) The message list line for that message should be left blank. If the message was unread you shouldn't see any more bold text in that pane (maybe after repainting). If the message was read then you shouldn't see any more normal text in that pane. If you toggle the message status from read to unread, you'll break both fonts.
is this the same as bug 338228?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> is this the same as bug 338228?

It doesn't look like it. That bug doesn't mention any display glitches, just warnings. I'm not getting that error message. In my case the only symptom is that after trying to display one of these subjects in the message list, TB can't display text with that font any more, but it acts as though nothing is wrong.

It may be that the trigger character in this case is tab rather than newline. Actually, I suppose I can't swear that the message subject strings have newlines in them.

Comment 3

12 years ago
I can confirm this bug with Thunderbird 2.0b1.

It's the newline that gets incorrectly rendered.  When I have newlines in subject headers, there is a small “NL” character ("␤") in the overview pane.

Tabs seem fine in the overview pane.  However, in the header box of the message pane, the tabs appears to be rendered so that additional space is inserted in the subject line.

The tab-newline combination in header fields should probably get special handling.

(It would be great if this bug could be fixed because it affects me quite frequently!)
(Reporter)

Comment 4

12 years ago
Resolving worksforme. I think bug 271312 is still valid, but the font breakage particular to cairo builds isn't happening any more.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.