google suggestions don't play well with IME

RESOLVED DUPLICATE of bug 354358

Status

()

RESOLVED DUPLICATE of bug 354358
13 years ago
8 years ago

People

(Reporter: channy, Unassigned)

Tracking

({intl})

unspecified
Firefox 2
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Search suggestion doesn't support 2byte language such as CJK right now. It's
different to detect finishing syllables. e.x onKeyUp and onKeyDown in
JavaScript. So Google made 2 byte langunage version.
http://www.google.co.jp/webhp?complete=1&hl=ja

Updated

13 years ago
Blocks: 335435

Comment 2

13 years ago
I'm not sure what '2byte languages' are. Probably, all scripts that use IME/input methods for input have 'this issue' so that the summary is being changed accordingly. BTW, I'm afraid I'm too slow to  get what attachment 222663 [details] tries to 'convey'. Channy, can you explain 'the issue' to me (off line)? 
Keywords: intl
Hardware: PC → All
Summary: search suggestion doesn't support 2byte language → search suggestion doesn't support scripts (CJK) that need input method/IMEs for input
Is this still the same in a3?
(Reporter)

Comment 4

13 years ago
> Is this still the same in a3?

it doesn't work still. I will explain this problem to Jungshik. 

Updated

13 years ago
Flags: blocking-firefox2?
Flags: blocking-firefox2? → blocking-firefox2+

Updated

13 years ago
Whiteboard: 181b1+

Comment 5

13 years ago
Masayuki and Jungshik, do you guys know if there's an easy way to get at the Japanese IME input before it's committed to the text field in Firefox?  I'd like to support Japanese Suggest specifically (which can use the IME input to give suggestions), but I don't know what APIs we have available.

Unfortunately, there's no specific Google Suggest support for Corean or Chinese characters right now.
This function may make to happy Japanese people. But I don't think so Chinese and Korean people. E.g., MS's Korean Global IME commits per character. Is this breaking current suggestions by the composition string on Korean language?

Jungshik:
What do you think?
(Reporter)

Comment 7

13 years ago
If it's possible as like http://www.google.co.jp/webhp?complete=1&hl=ja, korean character is nicely okay.
Target Milestone: Firefox 2 → Firefox 2 beta2
Y! seems to get this right, what's the difference in the implementation?
Whiteboard: 181b1+ → 181b1+ [mustfix]
Joe, you told me a while back that you were looking into this, what's up?
Summary: search suggestion doesn't support scripts (CJK) that need input method/IMEs for input → google suggestions don't play well with IME

Comment 10

13 years ago
My understanding is that we can support Japanese IME, if we can pass the partial IME input to the server (hence my question in comment #5, which I haven't gotten an answer to).  Google doesn't have Korean or Chinese versions of Suggest, though.
Simon, can you answer comment 5?
I'm not at all familiar with our IME code, I'm afraid. If Masayuki and Jungshik aren't available right now, maybe Aaron or Kyle can help?
Unfortunately, I don't have much time for this...

Comment 14

13 years ago
(In reply to comment #10)
> My understanding is that we can support Japanese IME, if we can pass the
> partial IME input to the server 

Looks to me like typeaheadfind supports this by handling HandleText(nsIDOMEvent* aTextEvent), not to be confused with the handleText method defined by the autocomplete code.
Target Milestone: Firefox 2 beta2 → Firefox 2
--> unblocking. As far as we can tell, this isn't breaking Google search, and we've got no traction on why this is different from Y! suggest. The primary search provider (Y!) works fine, so while we'd take a well baked patch, we're not going to block on this issue.
Assignee: mconnor → nobody
Flags: blocking-firefox2+ → blocking-firefox2-
Whiteboard: 181b1+ [mustfix]
(Reporter)

Comment 16

13 years ago
Bug 354358 is a primary bug to solve it.

Updated

13 years ago
Depends on: 354358
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354358
You need to log in before you can comment on or make changes to this bug.