Check boxes refresh but radio buttons and pull-down menus do not

RESOLVED DUPLICATE of bug 46845

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 46845
11 years ago
9 years ago

People

(Reporter: Linda, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

I have a piece of equipment which I can access via web page. A particular web page I open is set to refresh itself every 5 seconds. This web page contains information which could change from one refresh period to the next. The page source is re-generated by this piece of equipment each time a refresh occurs so that the updated information is shown after the refresh. There are certain situations when the checkboxes, radio button selections, and pull-down menu selections can change between refresh periods. I would expect to see the values change on the web interface when it refreshes every 5 seconds. This works fine with Windows Explorer, but in Firefox, only the check boxes and text boxes update automatically. The radio buttons and pull-down menus continue to display the old values. When I view the page source, it clearly shows the correct information being selected, but the web page still shows the old values for the radio button and pull-down menu but it shows the correct new information for the check boxes. The following shows the page source that was given when I entered CTRL+U from a Firefox browser.  The web page continued to show the "force_select" radio button with value 4095 being selected after I refreshed the screen even though the page source HTML shows value 3 being selected. I see this issue with pull-down menus as well. As I mentioned earlier, these fields update fine from IE. 

<HTML><HEAD><META HTTP-EQUIV="REFRESH" CONTENT="5; URL=/v_control?0"><TITLE>SubSys A Voter - Voter Control Panel</title>
</HEAD><BODY BGCOLOR="#f0f0f0" TEXT="#000000" LINK="#ff0000" VLINK="#0000ff">
<table border=0 width=100%><tr valign=top>
<td>
<img src="/files/viking.gif"><br>
<font size=2><br><b><a href="/index.html">Main Menu</a></b><br>
<br><b>Voter</b><br>
•&nbsp;<a href="/v_status?0">Status</a><br>
•&nbsp;<a href="/v_control?0">Control&nbsp;Panel</a><br>
•&nbsp;<a href="/v_maincfg?0">Main&nbsp;Configuration</a><br>
•&nbsp;<a href="/v_freqcfg?0">Frequency&nbsp;Configuration</a><br>
•&nbsp;<a href="/v_sitecfg?0">Site&nbsp;Configuration</a><br>
•&nbsp;<a href="/v_statistics?0">Statistics</a><br>
<br><b>Commands</b><br>
•&nbsp;<a href="/reboot.html">Reboot<br></a><br>
•&nbsp;<a href="/flash.html">Update FLASH</a><br>
•&nbsp;<a href="/debugconfig.html">Debug Flags</a><br>
•&nbsp;<a href="telnet://10.128.16.70/">Telnet Console</a><br>
•&nbsp;<a href="telnet://10.128.16.70:8000/">Debug Console</a><br>
</font></td><td bgcolor="#000000">&nbsp;</td><td>
<table width=95% border=0><tr><td align=left width=33%><font size=2><b>Voter (Build 0.1.12a)</b></font></td><td align=center width=33%><font size=2><b>SubSys A Voter</b></font></td><td align=right width=33%><font size=2><b>MAJOR 7:3 </b></font></td></tr><tr><td align=left width=33%%><font size=2><b>DSP (Build 2.1.2)</b></font></td><td></td><td align=right width=33%><font size=2><b>05/19/06 15:52:42</b></font></td></tr></table><center><img src="/files/line_1.gif"></center><center><br>
<form action="/postvotecontrol" method="POST"><b>Voter Control Panel</b><br><br><table border=1>
<tr><td>
<input type="hidden" name="v0" value="0"></td></tr>
<tr><td>
Receiver Id</td><td>
 1</td><td>
 2</td><td>
 3</td><td>
 4</td><td>
 5</td></tr>
<tr><td>
Selected</td><td><br></td><td><br></td><td><br></td><td><br></td><td><br></td></tr>
<tr><td>
Active</td><td><br></td><td><br></td><td><br></td><td><br></td><td><br></td></tr>
<tr><td>
Connected</td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#ff0000"><font size="1" color="#ffffff">No</font></td></tr>
<tr><td>
On Frequency</td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#00ff00"><font size="1" color="#ffffff">Yes</font></td><td bgcolor="#ff0000"><font size="1" color="#ffffff">No</font></td></tr>
<tr><td>
Signal</td><td align=center><br></td><td align=center><br></td><td align=center><br></td><td align=center><br></td><td align=center><br></td></tr>
<tr><td>
Receiver Inhibit</td><td>
<input type="checkbox" name="I1"  value="Enabled"></td><td>
<input type="checkbox" name="I2"  value="Enabled"></td><td>
<input type="checkbox" name="I3"  value="Enabled"></td><td>
<input type="checkbox" name="I4"  value="Enabled"></td><td>
<input type="checkbox" name="I5"  value="Enabled"></td></tr>
<tr><td ROWSPAN=3>Force Select</td><td>
<input type="radio" name="force_select" value="1"></td><td>
<input type="radio" name="force_select" value="2"></td><td>
<input type="radio" name="force_select" value="3" CHECKED></td><td>
<input type="radio" name="force_select" value="4"></td><td>
<input type="radio" name="force_select" value="5"></td></tr>
<tr><td COLSPAN=5><input type="radio" name="force_select" value=4095>Disable</td></tr>
<tr><td COLSPAN=5><select name="EmergTrump"><OPTION VALUE="0" SELECTED>Selection Overrides Emergency
<OPTION VALUE="1">Emergency Overrides Selection
</select></td></tr>

</table><br><input type="submit" value="Accept"></form></center></td></tr></table><center><hr></center></BODY>
</html>



Reproducible: Always

Steps to Reproduce:
1. Open a web page with one radio button selected from a radio set and one item from a menu selected.
2. Hit the refresh button
3. When the server re-sends the page, a have a different radio button "CHECKED" in the HTML and a different menu item "SELECTED"


Actual Results:  
* The Web page shows the original button selected before the refresh instead of the one that should be "CHECKED" as indicated by the HTML send after the refresh.
* The Web page shows the original menu item selected before the refresh instead of the one that now shows "SELECTED" in the HTML.

Expected Results:  
I expected to see the radio button shown as "CHECKED" in the page source as the one that is checked on the web page.

I expected to see the menu item shown as "SELECTED" in the page source as the one that is selected on the web page.

Comment 1

11 years ago
As a workaround you can add 'document.forms[0].reset()' in script tags at the end of the doc, and this does correctly show the 'CHECKED' values even though the original reload did not.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.