"Restart Bon Echo" button clickable while downloading extensions...

RESOLVED DUPLICATE of bug 337696

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 337696
12 years ago
10 years ago

People

(Reporter: Joshua, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1a2) Gecko/20060513 BonEcho/2.0a2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1a2) Gecko/20060513 BonEcho/2.0a2

While downloading an extension (DownThemAll! 0.9.9.2 in this case) within the Firefox Themes/Extensions Manager, the "Restart Bon Echo" button is clickable. This causes the the browser to immediately restart while the extension is still downloading, making it corrupt (non workable but no errors) upon restart.

Reproducible: Always

Steps to Reproduce:
1.Download extension DownThemeAll! 0.9.9.2. in the Extension/Theme Manager.
2.Press the "Restart Bon Echo" button while the extension is downloading.
3.Witness corrupted extension upon restart.

Actual Results:  
The extension was corrupt and had to be removed and redownloaded upon browser restart.

Expected Results:  
The "Restart Bon Echo" button should not be clickable while downloading an extension

I was using a brand new profile for this version of Firefox.
This is for all practical purposes the same as bug 337696 and will be fixed in that bug

*** This bug has been marked as a duplicate of 337696 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.