Closed Bug 338778 Opened 15 years ago Closed 5 years ago

Investigation - Typing jumps automatically to fast-find and can not fill out forms

Categories

(Toolkit :: Find Toolbar, defect)

1.8.0 Branch
x86
Windows XP
defect
Not set
minor
Points:
1

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: macsta187, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

If i have an instance of firefox opened (with tabs) for a long period of time (to check my email), when I open a second instance of firefox and try to type in the start google url, it will jump to fast find.
I have fast-find enabled because I do a lot of quick searches throughout the day, but it is weird when I make sure I click on an area to type in something and it goes straight to fast-find no matter what I do.  The already opened first instance is unaffected.  Usually closing and opening helps.

Reproducible: Didn't try




I have no mods installed for FireFox.  I did modify the about:config file, but that was only to enable more multiple downloads.
Blocks: findgrabs
Version: unspecified → 1.5.0.x Branch
Same problem. I've had it for a short while, but wouldn't be able to confirm if it is 1.5.0.5 only, but certainly on that realease. I've had it happen a few times. In Google's homepage, google news... Can't remember any more. I'll pay more attention to whatever it is the situation when this bug comes up. Could also be due to an extension. I have updated my extensions several times, but haven't added any for almost 6 months and the bug has only recently (a few weeks?) been showing up.
I experience this on a regular basis and I have not found a trigger for it.

The problem as I see it is that with the Find-As-You-Type feature enabled, on occasion the feature kicks in even though a form element such as a text area or input has been given focus.  Each key press is caught and searched for before it reaches the form element.

I have found two ways to stop this behavior, the first is to restart FireFox and the second is to open Option and press ok to immediately close it.  Neither is permanent and it will return eventually.
I get this intermittently and have for a long time, many releases back.  Its annoying, I don't know what triggers it to start but once it starts I have to shutdown and start the browser again.
Dan - how are you opening the second window? are you using the desktop shortcut/quicklaunch or are you using ctrl+n?  Can you reproduce this bug only by opening the extra windows with ctrl+n?
Product: Firefox → Toolkit
Whiteboard: [defect] p=0
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: [defect] p=0 → p=0
Summary: Typing jumps automatically to fast-find and can not fill out forms → Investigation - Typing jumps automatically to fast-find and can not fill out forms
Whiteboard: p=0 → p=1
Points: --- → 1
Flags: qe-verify?
Whiteboard: p=1
I can't reproduce this issue on Fx 46.

If you feel this issue was closed in error, please feel free to re-open.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.