Personal Toolbar overflow chevron not properly updated on resize

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
11 years ago
6 years ago

People

(Reporter: jag (Peter Annema), Assigned: jag (Peter Annema))

Tracking

({fixed-seamonkey1.1a})

Trunk
x86
Windows XP
fixed-seamonkey1.1a

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-seamonkey1.0.3)

Attachments

(2 attachments)

657 bytes, patch
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
625 bytes, patch
jag (Peter Annema)
: review+
neil@parkwaycc.co.uk
: superreview+
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: approval-seamonkey1.0.3+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
It checks that the event.target == document when it should be checking that event.target == window (this changed somewhere between 1.7 and 1.9). Patch coming up.
(Assignee)

Comment 1

11 years ago
Created attachment 222841 [details] [diff] [review]
Make the chevron code happy.
Attachment #222841 - Flags: superreview?(neil)
Attachment #222841 - Flags: review?(cst)

Updated

11 years ago
Attachment #222841 - Flags: superreview?(neil) → superreview+
Attachment #222841 - Flags: review?(cst) → review+
(Assignee)

Comment 2

11 years ago
Checking in bookmarksMenu.js;
/cvsroot/mozilla/xpfe/components/bookmarks/resources/bookmarksMenu.js,v  <--  bookmarksMenu.js
new revision: 1.25; previous revision: 1.24
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Created attachment 222869 [details] [diff] [review]
for 1.8 branch

Some quick testing doesn't show any breakage, but I couldn't really reproduce the original problem on 1.8.1 anyway.
Attachment #222869 - Flags: superreview?(neil)
Attachment #222869 - Flags: review?(jag)
(Assignee)

Updated

11 years ago
Attachment #222869 - Flags: review?(jag) → review+

Comment 4

11 years ago
Comment on attachment 222869 [details] [diff] [review]
for 1.8 branch

>-    else if (event.target != document)
>-      return; // only interested in chrome resizes
>+    // XXXcst - work around bug 295340 (broken event targets) on 1.8 branch
>+    //else if (event.target != document)
>+    //  return; // only interested in chrome resizes
Nit: you could have used /* ... */ to avoid changing lines
Attachment #222869 - Flags: superreview?(neil) → superreview+
Attachment #222869 - Flags: approval-seamonkey1.1a?
Are there issues on 1.8.0.x too?  Would the 1.8 patch fix them, if they exist?  If so, we should do this for SM1.0.3.

Comment 6

11 years ago
(In reply to comment #3)
>Some quick testing doesn't show any breakage, but I couldn't really reproduce
>the original problem on 1.8.1 anyway.
I think it depends on how you resize the window.

(In reply to comment #5)
>Are there issues on 1.8.0.x too?  Would the 1.8 patch fix them, if they exist? 
Yes, 1.8.0.x was cut from the 1.8.x branch.
Attachment #222869 - Flags: approval-seamonkey1.0.3?

Comment 7

11 years ago
Comment on attachment 222869 [details] [diff] [review]
for 1.8 branch

a=me for SM1.1a
first a=me for SM1.0.3
Attachment #222869 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+
Keywords: fixed-seamonkey1.1a
Whiteboard: [cst: land on 1.8.0 after SM1.0.2 ships]
*** Bug 305706 has been marked as a duplicate of this bug. ***
I already verified this as fixed over in bug 305706.
Status: RESOLVED → VERIFIED
Comment on attachment 222869 [details] [diff] [review]
for 1.8 branch

a=me,IanN
Attachment #222869 - Flags: approval-seamonkey1.0.3? → approval-seamonkey1.0.3+

Comment 11

11 years ago
I landed attachment 222869 [details] [diff] [review] on the 1.8.0 branch
Whiteboard: [cst: land on 1.8.0 after SM1.0.2 ships] → fixed-seamonkey1.0.3

Updated

6 years ago
Duplicate of this bug: 310776
You need to log in before you can comment on or make changes to this bug.