readonly textarea ignores backgound-color: #fff;

RESOLVED DUPLICATE of bug 279926

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 279926
12 years ago
12 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

A textarea with the readonly attribute will display a brownish background be default. If a background-color of white (white, #fff, or #ffffff) is set to the textarea, it will still display the brownish background color. No matter how the style is applied (class, id, textarea, inline style, etc) it doesn't work.

If the background-color is anything but pure white, it will show up. background-color #ccc shows as gray and the brownish background is gone.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.botsko.net/Test/readonly_textarea.html for a test.
2.
3.

Actual Results:  
background-color of white is ignored.

Expected Results:  
background-color should be set as any other color.

I posted the issue to the CSS-Discuss list without any results. This does not occur in IE, Safari, or even Firefox 1.5.0.3 for Mac. This doesn't appear to happen with any Windows versions, just XP. I have had several people confirm, so it's not just me.

Google searches reveal others have had this issue, but no resolution.
Looks like bug 279926 to me.


*** This bug has been marked as a duplicate of 279926 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.