Last Comment Bug 339111 - README.txt should be readme.txt (or the other way round?)
: README.txt should be readme.txt (or the other way round?)
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 2.0 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 08:15 PDT by Hendrik Maryns
Modified: 2011-09-04 05:36 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hendrik Maryns 2006-05-24 08:15:29 PDT
This was bug 338522:
I just installed 1.5.3 on Linux, untarring the archive gives me a directory
with the files readme.txt and README.txt, the second of which contains the
dutch translation of the first.  One of both should be renamed and the other
removed.
And this was the comment:
This is the same naming as in the en-US master file. You can file a bug for the
original Fx and not for the localization.
Therefore this new bug.
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2007-09-17 06:04:03 PDT
Hrm, if this is back in the dutch l10n component, than it's WONTFIX as the original l10n bug. I don't see what we're doing here, and if it's even still a problem.
Comment 2 Tim Maks van den Broek [:mad_maks] 2007-09-18 05:10:23 PDT
the reporter has changed it to the dutch l10n component, i do not now why. Marking it as WONTFIX
Comment 3 Hendrik Maryns 2007-10-25 07:46:47 PDT
The problem is still there.  If somebody could clearly explain where the problem lies, maybe I could solve it.  But really I think Tim Maks is responsible here.

To reproduce: download http://download.mozilla.org/?product=firefox-2.0.0.8&os=linux&lang=nl and unpack.  
Comment 4 Tim Maks van den Broek [:mad_maks] 2007-10-26 03:48:40 PDT
if you do a search in the l10n cvs dir http://lxr.mozilla.org/l10n/find?string=readme.txt you will see everybody uses README.txt.

if you do a search in the mozilla cvs dir 
http://lxr.mozilla.org/mozilla/find?string=readme.txt you will see that in browser/locales/en-US also README.txt is used.

so i don't understand where it comes from but it is not a dutch l10n bug 
Comment 5 Tim Maks van den Broek [:mad_maks] 2007-10-26 10:57:31 PDT
did you also downloaded other languages to check if it is really a nl problem?
Comment 6 Hendrik Maryns 2007-10-27 09:14:35 PDT
French Firefox seems to have the same problem: README.txt in the proper language, readme.txt in English.

Thunderbird only has the localized README.txt.

I cannot check whether this is confined to Linux, since Windows uses an installer and I did not manage to read the Mac image (yet).

As a sidenote: I think it looks funny, having the file name in all caps, but the extension in lower case.  I think the convention on Linux is simply README, without the .txt.

I hope I chose the right product and component now, since it seems to be a site-wide problem.
Comment 7 Hendrik Maryns 2007-10-27 10:35:37 PDT
As far as I can see (by studying the .dmg file under Linux), the problem is not present on macosx.
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-27 14:47:47 PDT
The files provided by the app are just zipped up by 7-Zip and copied by the installer. Not an installer bug.
Comment 9 Tim Maks van den Broek [:mad_maks] 2009-04-21 03:24:08 PDT
Hendrik, do you still see this issue?
Comment 10 Tim Maks van den Broek [:mad_maks] 2011-09-04 05:36:16 PDT
Readme.txt is removed http://hg.mozilla.org/l10n-central/nl/rev/0737bfaa58e0

so this bug is not valid anymore

Note You need to log in before you can comment on or make changes to this bug.