no focus event fired for Preference dialog when the first time open

RESOLVED DUPLICATE of bug 339210

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 339210
12 years ago
12 years ago

People

(Reporter: Evan Yan, Unassigned)

Tracking

({access})

Trunk
x86
Linux
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
start firefox, when open Preference dialog the first time, no focus event fired for the focused image tab buttons.
but if you close the dialog and then open it again, focus event fired correctly.

I can reproduce this bug on the trunk build, but not on firefox 1.5.
(Reporter)

Comment 1

12 years ago
there are some thing strange...

if "General" tab of Preference dialog is active, it behaviors as what's described in this bug. 

events log by at-poke:

generic event 'focus:' A|co|ac:list item:General:(0) (0)
window event 'window:deactivate' (0) (0) on A|co:frame:(...): with title (...)
generic event 'focus:' A|co:dialog:Minefield Preferences:(0) (0)
window event 'window:activate' (0) (0) on A|co:dialog:Minefield Preferences: with title 'Minefield Preferences'

but, if any other tab is active, say "Privacy", "Content", focus event is never fired, as bug 339210 described

events log by at-poke:

window event 'window:deactivate' (0) (0) on A|co:frame:(...): with title (...)
window event 'window:activate' (0) (0) on A|co:dialog:Minefield Preferences: with title 'Minefield Preferences'

Updated

12 years ago
Keywords: access
(Reporter)

Comment 2

12 years ago
in the latest trunk build, there is no "General" tab in preference dialog any more. this bug is totally a dupe of bug 339210 now.

*** This bug has been marked as a duplicate of 339210 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.